Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - wxwidgets2.8-light

Package Base Details: wxwidgets2.8-light

Git Clone URL: https://aur-dev.archlinux.org/wxwidgets2.8-light.git (read-only)
Submitter: sl1pkn07
Maintainer: None
Last Packager: sl1pkn07
Votes: 0
Popularity: 0.000000
First Submitted: 2014-09-29 09:41
Last Updated: 2015-12-11 18:19

Latest Comments

sl1pkn07 commented on 2016-10-16 17:31

configure you git installation first

user1549751245 commented on 2016-10-16 17:26

I get this error when compiling:

Extracting sources...
-> Creating working copy of wxWidgets git repo...
Cloning into 'wxwidgets'...
Switched to a new branch 'makepkg'
==> Starting prepare()...

*** Please tell me who you are.


git config --global user.email "you@example.com"
git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

fatal: empty ident name (for <(null)>) not allowed
==> ERROR: A failure occurred in prepare().
==> ERROR: Makepkg was unable to build wxwidgets-light.
==> Restart building wxbase-light ? [y/N]

sl1pkn07 commented on 2015-02-09 16:04

ow men. fixed

sorry and greetings

DarkElf commented on 2015-02-09 15:50

I get this error during compilation:

checking for GTK+ version...
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

Do you have any solution for this?