Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - linux-pf

Package Base Details: linux-pf

Git Clone URL: https://aur-dev.archlinux.org/linux-pf.git (read-only)
Submitter: nous
Maintainer: Thaodan
Last Packager: Thaodan
Votes: 177
Popularity: 2.013356
First Submitted: 2011-07-24 12:01
Last Updated: 2017-01-18 19:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

walkindude commented on 2016-10-10 11:35

@tamjan
same for me. solved by setting CONFIG_STACK_VALIDATION=y in config:
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=26660a4046b171a752e72a1dd32153230234fe3a&utm_source=anzwix

tamjan commented on 2016-10-10 11:06

On my box, objtool isn't built when the PKGBUILD wants to install the binary. Inserting a "( cd tools/objtool && make )" before "cp -a tools/objtool/objtool ${pkgdir}/usr/lib/modules/${_kernver}/build/tools/objtool/" makes it not fail. No idea if it's a good thing to do, though.

Thaodan commented on 2016-10-09 11:21

Hey I updated the pkg yesterday and synced the configs with the configs from the ARCH kernel, I used the aufs for the rcN kernel since theres no version for 4.8. if you get an issues see this:
https://twitter.com/pfkernel/status/785062319747436544

there's currently a bug that's is described in the tweet.

xianai commented on 2016-10-05 03:49

Update:

http://kerneldedup.org/download/uksm/0.1.2.5/uksm-0.1.2.5-for-v4.8.patch

xianai commented on 2016-09-25 08:31

Hi all,

UKSM for v4.7 was officially released.

http://kerneldedup.org/download/uksm/0.1.2.5/uksm-0.1.2.5-for-v4.7.patch

Please feedback at:
http://forum.kerneldedup.org/

quequotion commented on 2016-09-21 03:24

>kogone
Did you ever get a response?

If i run tuxoniceui --test it seems to be operational, but I haven't been able to suspend to disk (swapfile) for a while now with this message at boot:

"resume: tux-on-ice syntax detected, but no support found"

EDIT; yes, it has been removed, as of version 4.6-pf1 in June:
https://pf.natalenko.name/news/?p=181

Thaodan commented on 2016-08-31 12:19

The pkg is now also on gitlab where I test things first before pushing them into the aur: https://gitlab.com/Thaodan/linux-pf

Thaodan commented on 2016-08-31 12:16

I tested menuconfig and nconfig, both worked fine for me.
I renamed the modprobe-db stuff, changed the path of vmlinux as suggested.
Also I splittet the preset from the actual package.
With this change it is possible to use a kernel build for every device but use a specific preset if needed.
The if the default preset is installed nothing is changed.

Thaodan commented on 2016-08-10 11:51

nvidia-pf has the patch already too (:

tuankiet65 commented on 2016-08-10 11:46

If you are using this with nvidia-dkms, you may want to update nvidia-dkms to 367.35-2 (currently in testing, should be released once linux-4.7 has gone out of testing) or apply this patch by hand https://git.archlinux.org/svntogit/packages.git/tree/trunk/0001-linux-4.7-x86_64.patch?h=packages/nvidia