Package Base Details: linux-mainline

Git Clone URL: https://aur-dev.archlinux.org/linux-mainline.git (read-only)
Submitter: miffe
Maintainer: miffe
Last Packager: miffe
Votes: 188
Popularity: 5.668634
First Submitted: 2011-07-22 06:50
Last Updated: 2017-01-30 14:12

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

lesto commented on 2015-12-16 20:13

when compiling linux-mainline-header i get:

==> Starting package_linux-mainline-headers()...
cp: cannot stat ‘arch//Makefile’: No such file or directory

sonny commented on 2015-11-24 17:56

I'm getting the following error

kernel/sys.c: In function ‘override_release’:
kernel/sys.c:1133:28: error: expected expression before ‘>>’ token
v = ((LINUX_VERSION_CODE >> 8) & 0xff) + 60;
^
scripts/Makefile.build:258: recipe for target 'kernel/sys.o' failed
make[1]: *** [kernel/sys.o] Error 1
Makefile:943: recipe for target 'kernel' failed
make: *** [kernel] Error 2

lesto commented on 2015-11-24 00:00

same problem here!
seems it should be only in linux-mainline-docs right?

thevoidnn commented on 2015-11-20 23:43

error: failed to commit transaction (conflicting files)
/usr/lib/modules/4.4.0-rc1-mainline/build/Documentation/kbuild/Kconfig.recursion-issue-01 exists in both 'linux-mainline-docs' and 'linux-mainline-headers'
/usr/lib/modules/4.4.0-rc1-mainline/build/Documentation/kbuild/Kconfig.recursion-issue-02 exists in both 'linux-mainline-docs' and 'linux-mainline-headers'
/usr/lib/modules/4.4.0-rc1-mainline/build/Documentation/kbuild/Kconfig.select-break exists in both 'linux-mainline-docs' and 'linux-mainline-headers'
Errors occurred, no packages were upgraded.


(had to install kernel manually (no yaourt), omitted docs package)

miffe commented on 2015-11-20 17:47

@darkbasic: You're right. A | had gone missing from row 50, so the patch was never applied. Fixed in -2

darkbasic commented on 2015-11-20 17:28

@miffe
I mean that it doesn't really apply the patch: when you uncomment "make nconfig" in the ebuild you get a 4.3 kernel nconfig. I even opened the Makefile inside the src directory and I can see a 4.3 version. I even tried to apply the 4.4-rc1 patch inside the src directory while it was compiling and it applied flawlessly, meaning it didn't apply before.

miffe commented on 2015-11-20 15:17

@darkbasic: What do you mean? It's applied on row 50 in the PKGBUILD.

@BugMaze: That looks like an issue with the linux-docs/headers packages not linux-mainline.

darkbasic commented on 2015-11-20 14:42

It doesn't apply patch-4.4-rc1.xz.

BugMaze commented on 2015-11-17 06:35

Compiled it today , but it won't install :

(3/3) checking for file conflicts [##############################################################] 100%
error: failed to commit transaction (conflicting files)
/usr/lib/modules/4.4.0-rc1-ARCH/build/Documentation/kbuild/Kconfig.recursion-issue-01 exists in both 'linux-docs' and 'linux-headers'
/usr/lib/modules/4.4.0-rc1-ARCH/build/Documentation/kbuild/Kconfig.recursion-issue-02 exists in both 'linux-docs' and 'linux-headers'
/usr/lib/modules/4.4.0-rc1-ARCH/build/Documentation/kbuild/Kconfig.select-break exists in both 'linux-docs' and 'linux-headers'
Errors occurred, no packages were upgraded.

darkbasic commented on 2015-11-16 17:22

Please bump to 4.4-rc1.