Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - linux-mainline

Package Base Details: linux-mainline

Git Clone URL: https://aur-dev.archlinux.org/linux-mainline.git (read-only)
Submitter: miffe
Maintainer: miffe
Last Packager: miffe
Votes: 188
Popularity: 5.668634
First Submitted: 2011-07-22 06:50
Last Updated: 2017-01-30 14:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

blueyed commented on 2016-11-18 01:16

@lesto (and others):
Are you using `make localmodconfig`?

I think it would be good to have some (wiki) article about this package:

1. how and if `make localmodconfig` is supported / supposed to work. Just use it instead of "make olddefconfig" in the PKGBUILD?

2. how to change the config and rebuild the package without building it from scratch?

2a. When not cleaning the "src" directory you will get messages like the following during patching:

The next patch would create the file .gitattributes,
which already exists! Assume -R? [n]

Thanks!

lesto commented on 2016-11-17 20:58

rc5 still need CONFIG_MODVERSIONS to be disabled for both my pc, is that normal? shoun't be fixed by RC3?

Boohbah commented on 2016-11-03 21:45

frosth:

Thanks for the link. Disabling CONFIG_MODVERSIONS fixed it.

prazola commented on 2016-10-21 17:09

This build hangs on shutdown and reboot on all my PCs like every rc1 since 4.5.
But this time i don't see any kernel panic message, just black monitor and computer don't turn off.

frosth commented on 2016-10-16 15:29

you can fixed it by disabling CONFIG_MODVERSIONS,
more info:
https://www.phoronix.com/forums/forum/phoronix/latest-phoronix-articles/904950-linux-4-9-rc1-kernel-released-early?p=905057#post905057

enckse commented on 2016-10-16 13:53

After the upgrade to 4.9rc1-1, boot could not find the dev mapper for my root device (systemd-boot + luks + lvm) so I had an unbootable machine (didn't get any errors/warnings during mkinit or install).

I've downgraded back to linux-mainline 4.8-1 but word of warning and/or any advice/input is welcome

miffe commented on 2016-09-15 10:50

@mirh: They dont change that often. See https://git.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
And it seems pointless to update them just to get another version string in a comment.

mirh commented on 2016-09-14 19:37

They can even be a week old, but if this is 4.8rc6, why the header of the file mentions 4.7.3-2 ?

miffe commented on 2016-08-29 14:04

They are a week old. And they are necessary.

mirh commented on 2016-08-29 13:22

Config files this package comes with are, for as much default, quite old and trigger some warnings.
Could they be updated?

Or even better, do we really need to ship them?