Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - kodi-devel

Package Base Details: kodi-devel

Git Clone URL: https://aur-dev.archlinux.org/kodi-devel.git (read-only)
Submitter: alucryd
Maintainer: MarcinWieczorek
Last Packager: MarcinWieczorek
Votes: 24
Popularity: 1.120006
First Submitted: 2014-08-11 23:33
Last Updated: 2017-01-04 18:41

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

Freso commented on 2015-09-30 07:32

@Raansu Because you *need* it to build the package (= $makedepend), but you don't *need* it to run it once it's been build (!= $depend), even if it can *optionally* provide support for libCEC if it is installed (= $optdepend).

There's probably a ./configure flag or something you can set in the PKGBUILD to get Kodi to compile without CEC support, in which case you can remove the $makedepend from your local copy of the PKGBUILD. Look at Kodi's build instructions for help on that.

Raansu commented on 2015-09-29 18:25

why is kodi-devel-libcec both a optdepend and makedepend? which is it? I only noticed because kodi-devel-libcec will not compile at the moment for issues beyond me.

dhead666 commented on 2015-08-11 01:59

I should point that atm the adsp addons appearing to be highly unstable and crashing kodi.
as we are on monthly development releases this is reasonable, so the adsp addon packages will stay available here on AUR for testing.

the whole adsp feature seem to be still in active development and the main developer pushing this looks to be pretty busy so I don't think logs and backtraces would help much ATM.

you can always disable the adsp feature in kodi or remove the adsp addon packages ( kodi-devel-adsp-* ).

dhead666 commented on 2015-08-02 19:48

adsp-biquad-filters is now available as kodi-devel-adsp-biquad-filters.

dhead666 commented on 2015-08-02 00:53

Bumped up to 16.0a1.
Notice the move from libcec to own kodi-devel-libcec as libplatform added to Community (due to libcec bump).

ADSP addons are now available, ATM adsp-biquad-filters is missing because of an issue with a depend.

dhead666 commented on 2015-05-26 09:59

Hi Sunday,

I'm going to change the naming of the addons to kodi-devel-* so they will be listed together.

The cmake addons build system in Kodi's source tree (at least in 15beta1) didn't do what I wanted so although I tried to avoid it I believe I'll have to create a package for each binary addon (and not group them together in category package, like kodi-addon-pvr or kodi-addon-audio-decoders).

I'll update this package and add all the missing binary addons next week.

Sunday commented on 2015-05-21 21:20

Hey, thanks for this nice package. Seemed the best way to get a recent kodi on my htpc. I even submitted a kodi-addon-pvr-mythtv-devel that works with it. Are you still going to update this? I bumped it even to 15.0b1 without any problems and would submit the corresponding kodi-addon-pvr-mythtv-devel when this gets updated.

dhead666 commented on 2015-04-04 18:51

The package will be updated later, sorry for the delay but I'm making some changes so the binary addons will be included as split packages as having a separate package for each addon is not the best approach (I'm guessing 20+ binary addons for Isengard, and if Retroplayer will be merged then 70+ binary addons).

If you're really need to test 15.0a2 now then just change the pkgver variable, the package will be built without issues, but you'll miss some non FFmpeg audio decoders.
When I will update the package I will set pkgrel=2 so you could rebuild the updated package with the split packages.

dhead666 commented on 2015-03-19 06:35

I updated the PKGBUILD with a workaround for bluez 5.29, noticed that I had to disable wiiremote eventclient but the rest of the eventclients should work.

I forced the package update with a pgkrel bump because of a report about kodi crashing after updating samba to 4.2.0, if kodi 15.0a1 doesn't crash on your system with samba 4.2.0 then you don't need to rebuild.

Also notice that I added a quick way to test new features by adding a Github PR number to "prlist=()"

dhead666 commented on 2015-03-18 16:37

heads-up: bluez 5.29 breaks kodi's compilation.