Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - java8-openjdk

Package Base Details: java8-openjdk

Git Clone URL: https://aur-dev.archlinux.org/java8-openjdk.git (read-only)
Keywords: fonts infinality java jdk jre
Submitter: chrbayer
Maintainer: None
Last Packager: gim
Votes: 25
Popularity: 2.553311
First Submitted: 2014-09-15 20:06
Last Updated: 2017-02-02 09:11

Pinned Comments

gim commented on 2016-02-22 14:07

Prebuilt packages by me are available at https://www.dropbox.com/sh/33ia4nzd2cdigvy/AADzw5132rjMLi5GhMKxgrOma?dl=0

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 Next › Last »

saraivinha commented on 2015-06-04 15:04

I installed this on a fresh arch install successfuly. However when I try to run an application (like intellij) it uses all my memory instantaneously and my mouse cursor starts lagging. This problem does not occur switching to the official jdk. I've tried install it again multiple times with the same result. Does anyone experiences the same problem?

chrbayer commented on 2015-05-20 17:09

I think you can just change it to jdk8 and try it :-) The usage of jdk7 is from upsteam, so I kept it.

Loong commented on 2015-05-20 16:09

There is a jdk7-openjdk in makedepends, can I just change it to jdk8-openjdk, cause I am currently having jdk8-openjdk installed and don't want to intall another jdk.

gim commented on 2015-04-29 13:29

Huulivoide, we know that. It was outdated there though.

gim commented on 2015-04-29 13:26

Huulivoide, we know that. It's outdated there though.

Huulivoide commented on 2015-04-29 09:36

gim, chrbayer: This package is in the Infinality repo. It has been
for quite a while already, I don't even remeber when I switch to it
from the regular openjdk package.

gim commented on 2015-04-25 15:58

chrbayer, AUR packages are never obsolete until they're moved to the official repository.

chrbayer commented on 2015-04-25 14:52

I have updated the package, hoped it would appear in the infinality repo, so this package would be obsolete... But it seams I have to keep updating :-)

gim commented on 2015-04-25 10:36

Updated PKGBUILD: https://www.dropbox.com/s/1nn7ju27da5woog/java8-openjdk-8.u45-1.src.tar.gz

It took 47 minutes to build this on Intel Core i5-4200U. In case you have any
issues building this, or it takes forever to build on your hardware, you might
want to use precompiled packages if you trust me (and you probably shouldn't
trust random guys like me).
https://www.dropbox.com/sh/33ia4nzd2cdigvy/AADzw5132rjMLi5GhMKxgrOma?dl=0

I also included a Haswell-optimized build there (for 4th gen Intel Core i5).

gim commented on 2015-04-25 10:36

Updated PKGBUILD: https://www.dropbox.com/s/1nn7ju27da5woog/java8-openjdk-8.u45-1.src.tar.gz

It took 47 minutes to build this on Intel Core i5-4200U. In case you have any issues building this, or it takes forever to build on your hardware, you might want to use precompiled packages if you trust me (and you probably shouldn't trust random guys like me).
https://www.dropbox.com/sh/33ia4nzd2cdigvy/AADzw5132rjMLi5GhMKxgrOma?dl=0

I also included a Haswell-optimized build there (for 4th gen Intel Core i5).