Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - amdgpu-pro-installer

Package Base Details: amdgpu-pro-installer

Git Clone URL: https://aur-dev.archlinux.org/amdgpu-pro-installer.git (read-only)
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 46
Popularity: 8.268778
First Submitted: 2016-03-28 22:44
Last Updated: 2016-08-29 16:36

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:

https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

Discussion of 16.60 update is here: https://github.com/corngood/archlinux-amdgpu/pull/28

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

viennaa commented on 2016-12-07 08:34

Is there a way to build the 16.30 version against a kernel? On my 4.8.12 it always fails to build DKMS.

If you manage to build it on a specific kernel version, please share.

tranqtech commented on 2016-12-07 05:15

@nmset
Managed to install with your pkbuild, but if there's no 32-bit libs for your build is there a known way to get steam working?

Paullux commented on 2016-12-05 12:32

@nmset ok

nmset commented on 2016-12-05 08:27

@Paullux : The PKGBUILD I linked does not install 32-bit libraries at all. On further testing, I could not get an X session if I co-install the 32-bit libraries.

Paullux commented on 2016-12-04 17:27

@nmset The 32 bits applications (like 'steam' and 'the lord of the rings online' with wine) doesn't work with your PKGBUILD (there is artefact).
http://hpics.li/831ece1

nmset commented on 2016-12-03 17:28

@Lopo : I guess you should use [pacman -Syu --ignore ocl-icd], as amdgpu-pro here uses its own ocl libraries.

Lopo commented on 2016-12-03 15:50

==> Package upgrade only (new release):
extra/imagemagick 6.9.6.6-1 1 -> 2
==> New package :
extra/ocl-icd 2.2.9-1 (required by imagemagick)
.
.
looking for conflicting packages...
:: ocl-icd and amdgpu-pro-libopencl-dev are in conflict (libcl). Remove amdgpu-pro-libopencl-dev? [y/N]

for N:
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: ocl-icd and amdgpu-pro-libopencl-dev are in conflict

for Y:
error: failed to prepare transaction (could not satisfy dependencies)
:: amdgpu-pro-computing: removing amdgpu-pro-libopencl-dev breaks dependency 'amdgpu-pro-libopencl-dev=16.30.3.315407-2'

Dokter.Bibber commented on 2016-12-01 14:28

I'm seeing some graphics glitches with the OS-drivers from the main repo : https://bbs.archlinux.org/viewtopic.php?id=220172
But I wouldn't want to land in a situation where I'm worse off.
(1) So does this package build without issues with the current version?

(3) Does this package give me control over the fan speed, or does it maybe control the fan speed itself?

nmset commented on 2016-11-30 08:30

@Stonewall : Here is how I do that :

http://pastebin.com/uksMGgNn

Please read the header comments.

Stonewall commented on 2016-11-29 23:11

Hey @nmset could you give a little more information on how you are getting this to working?