Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - amdgpu-pro-installer

Package Base Details: amdgpu-pro-installer

Git Clone URL: https://aur-dev.archlinux.org/amdgpu-pro-installer.git (read-only)
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 46
Popularity: 8.268778
First Submitted: 2016-03-28 22:44
Last Updated: 2016-08-29 16:36

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:

https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

Discussion of 16.60 update is here: https://github.com/corngood/archlinux-amdgpu/pull/28

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

adb commented on 2016-12-12 20:59

@nmset: Are you planning to take the role of a maintainer for this package? I was going to fork the repo and have a go at patching it for 16.50, with what we have so far.

tpruvot commented on 2016-12-11 19:53

Look like AMD remove all older drivers packages, real pain to find a mirror.

For OpenCL, the last stable for me is the libamdocl64.so from 16.30 (16.40 is unstable) and the first 16.50 which use Clang 3.9 seems.. different.

Else, well this first 16.50 kernel module is not proper imo.. lot of warnings, some reggressions in kernel backports (ttm)

The encountered OpenCL problems can be reproduced on Windows too. For now i use all the latest stuff with the old ocl64 lib which seems to work fine.

Another thing, the new RHEL 7.2 installer seems closer to ARCH (and Slackware) paths, it uses lib64 style for the libraries.

nmset commented on 2016-12-11 08:44

@marcio : Your Xorg log says KMS is not being used. You should check that your boot command line does not have any KMS inhibitors like 'nomodeset'. Don't use any xorg.conf file neither. That's all I can say.

marcio commented on 2016-12-10 23:38

@nmset I'm having some trouble trying to get amdgpu-pro working with RX 480.

After reboot gdm do not start and on journalctl I have that output:

http://ap.imagensbrasil.org/image/EE6y0Y

tks

nmset commented on 2016-12-09 13:58

@Corngood : regarding conformance, it does not use standard locations (/usr/lib...) as I don't want to mess up a system if things go wrong. This forces to declare other library locations in /etc/ld.so.conf.d, and optionally a long list of LD_LIBRARY_PATH variable, which gets not very clean, though it works. It doesn't always use quoted variables as I observed that unpacking the DEB packages would fail otherwise. And it's not clear how to get a direct download link from AMD's website on every release.

Corngood commented on 2016-12-09 13:42

@nmset go for it. I haven't had time to do any work on arch lately, so I'm happy to take any contributions, or even hand over maintainership if someone wants to take it on.

What's non-conformant about your script?

nmset commented on 2016-12-09 10:01

Here is a 32/64-bit PKGBUILD for 16.50 :

http://pastebin.com/Pfsirxtb

@Corngood : I don't have any intent to hijack your repository, I just don't have any other outlet to share a PKGBUILD that doesn't conform to AUR standards. If you feel I should stop linking here, I'll do so.

LiberteCzech commented on 2016-12-09 06:18

AMDGPU-PRO 16.50 released.
GCN 1.0 enable by default by DKMS.

nmset commented on 2016-12-08 09:42

@Lopo :
>there is nothing to do
Your system is up to date.
>:: imagemagick: requires opencl-icd-loader
An acceptable sacrifice for many probably.

Lopo commented on 2016-12-08 08:45

@nmset
pacman -Syu --ignore ocl-icd
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
archlinuxfr is up to date
:: Starting full system upgrade...
resolving dependencies...
warning: ignoring package ocl-icd-2.2.9-2
warning: cannot resolve "opencl-icd-loader", a dependency of "imagemagick"
:: The following package cannot be upgraded due to unresolvable dependencies:
imagemagick

:: Do you want to skip the above package for this upgrade? [y/N]

N
error: failed to prepare transaction (could not satisfy dependencies)
:: imagemagick: requires opencl-icd-loader

Y
looking for conflicting packages...
there is nothing to do