Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - amdgpu-pro-installer

Package Base Details: amdgpu-pro-installer

Git Clone URL: https://aur-dev.archlinux.org/amdgpu-pro-installer.git (read-only)
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 46
Popularity: 8.268778
First Submitted: 2016-03-28 22:44
Last Updated: 2016-08-29 16:36

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:

https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

Discussion of 16.60 update is here: https://github.com/corngood/archlinux-amdgpu/pull/28

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Renfield commented on 2016-12-31 20:27

I've just got a Radeon RX 480. makepkg fails:

==> Validating source files with sha256sums...
amdgpu-pro_16.30.3-315407.tar.xz ... FAILED

==> ERROR: One or more files did not pass the validity check!

I have tried twice to be sure it wasn't just really a corrupted download.

darkbasic commented on 2016-12-29 12:06

Here is the link to the DKMS patches for amdgpu-pro 16.50: https://drive.google.com/drive/folders/0Bwe9Wtc-5xF1TzVDZW54UnRJYkU
They should work up to 4.7, but I only tested 4.4 and 4.7.

If you are interested you can find some fresh benchmarks here: https://www.phoronix.com/scan.php?page=news_item&px=EOY2016-Arch-AMD-Linux

Avoid using recent kernels with amdgpu-pro because they don't perform well, I suggest you to use linux from 4.4 up to 4.7.

nmset's package is a bit rough but works fine, unfortunately I didn't have enough time to properly update the 16.30 one.

nmset commented on 2016-12-23 08:28

@parkerlreed : I guess there's no volunteer to take on this maintenance, I just can't as I tinker a lot as a hobby only.

parkerlreed commented on 2016-12-23 03:45

@nmset Is there a reason 16.50 is not part of the main AUR package yet?

nmset commented on 2016-12-21 15:01

@DarenK : You should not be having this error with 16.50 and http://pastebin.com/Pfsirxtb

Good luck.

DarenK commented on 2016-12-21 14:42

When installing I'm getting this:

:: amdgpu-pro-libopencl-dev and ocl-icd are in conflict (libcl). Remove ocl-icd? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: imagemagick: removing ocl-icd breaks dependency 'opencl-icd-loader'

It doesn't replace the opencl libraries needed by imagemagick, any solution?

libcg commented on 2016-12-18 08:40

I would be interested in maintaining the DKMS part. I'll try to get the 16.50 driver rolling soon. My goal is to get the Vulkan and OpenCL drivers working along with Mesa.

@Corngood could you make this package orphan? Thanks.

viennaa commented on 2016-12-15 12:25

@Muxoid add --ignore ocl-icd to pacman command

Muxoid commented on 2016-12-14 23:07

:: ocl-icd and amdgpu-pro-libopencl-dev are in conflict (libcl)

nmset commented on 2016-12-12 21:50

@adb : No, I don't intend to be a maintainer of this package. I just wished to share what I did to get to work what AMD releases. It would be nice that you fork to a clean package.