Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: zsh-zim-git r269.61ff601-1

Git Clone URL: https://aur-dev.archlinux.org/zsh-zim-git.git (read-only)
Package Base: zsh-zim-git
Description: ZIM - Zsh IMproved
Upstream URL: https://github.com/Eriner/zim
Licenses: MIT
Submitter: ishitatsuyuki
Maintainer: ishitatsuyuki (Eriner)
Last Packager: ishitatsuyuki
Votes: 13
Popularity: 1.060385
First Submitted: 2015-12-28 02:13
Last Updated: 2017-01-24 11:46

Dependencies (4)

Required by (3)

Sources (2)

Latest Comments

1 2 3 Next › Last »

9lo commented on 2017-01-23 14:48

`rsync` might have to be added as a dependency.

Got an error:
`.../zsh-zim-git/PKGBUILD: line 50: rsync: command not found`

Rhinoceros commented on 2017-01-23 11:04

Yep, I'm at 27cdd5cefa6f26d4bc57a8aa2d19d13db1db44bf. I've even been totally cleaning the repository with `git clean -dff` before `makepkg`.

Hmmm… so it seems that `zsh -l` and `zsh --login` also create the same errors for me as tmux and tty. However, again, I get no problem with a "normal" shell, where I just have `/bin/zsh` defined in `/etc/passwd`.

ishitatsuyuki commented on 2017-01-23 10:58

Please make sure you're at 27cdd5c (AUR git), and used the -f option to rebuild the package (I didn't change the package revision, sorry).

zsh -l (or --login) loads zlogin, which tries to precompile the files. tmux and tty also runs a login shell.

Rhinoceros commented on 2017-01-23 10:55

Did you mean with the one you pushed before my last comment, or have you forgotten to push a new one? I definitely pulled the last changes.

I'm not sure what `zsh --login` does exactly. I can't find `--login` in `man zshall`. However, tmux *isn't* exactly the same. In a new terminal emulator, zsh loads fine with no warning. However, if I manually start `tmux`, then I get the errors as described. Actually, I get these same errors if I log into a tty shell, so you might be able to reproduce with that too.

ishitatsuyuki commented on 2017-01-23 10:39

I'm pretty confident with the current one, have you really fetched the latest changes? I cannot reproduce anymore.

tmux is basically a login shell, zsh --login does the same thing.

Rhinoceros commented on 2017-01-22 09:52

This time when upgrading, I get

(1/1) reinstalling zsh-zim-git [##############] 100%
/usr/lib/zim/templates/zlogin:24: no matches found: /root/.zcomp^(*.zwc)(.)

Then I still get the same errors as before in tmux. Are you testing (and seeing errors) in tmux too?

ishitatsuyuki commented on 2017-01-22 08:27

Sorry, I was testing to roughly. I feel stupid now :P

@Rhinoceros, please try again, this one should finally behave correctly.

Rhinoceros commented on 2017-01-22 08:03

This time there is definitely no error on upgrading, but I still get the error in tmux. Thanks again for trying, though. Does anyone know exactly what the error implies? It's not like I use tmux all the time anyway…

ishitatsuyuki commented on 2017-01-22 06:12

@Rhinoceros, I hope this time works for you.

Rhinoceros commented on 2017-01-21 21:19

Oh, I just upgraded again, and now I get the following error. I'm not sure if I actually got it before and didn't notice.

(1/1) upgrading zsh-zim-git [############] 100%
zsh: no matches found: /root/.zcomp^(*.zwc)(.)
error: command failed to execute correctly