Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - xf86-input-synaptics-led

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: xf86-input-synaptics-led 1.9.0-1

Git Clone URL: https://aur-dev.archlinux.org/xf86-input-synaptics-led.git (read-only)
Package Base: xf86-input-synaptics-led
Description: Synaptics driver for notebook touchpads (with LED disable support)
Upstream URL: http://xorg.freedesktop.org/
Licenses: custom
Groups: xorg-drivers
Conflicts: synaptics, xf86-input-synaptics
Provides: synaptics, xf86-input-synaptics
Replaces: synaptics
Submitter: vantu5z
Maintainer: vantu5z
Last Packager: vantu5z
Votes: 0
Popularity: 0.000000
First Submitted: 2015-10-02 06:37
Last Updated: 2016-11-30 08:12

Required by (6)

Sources (2)

Latest Comments

« First ‹ Previous 1 2

vantu5z commented on 2015-10-30 05:53

Strange, I don't have such error on 4.2.4-1 and lts kernel.
Now in repo 4.2.5-1 kernel, try to update system.
After kernel update, before installing LED packages - reboot system.

dhemaseka commented on 2015-10-29 18:06

hey thanks for the update, but unfortunately the new package give me error while building psmouse.ko
error output was like this:


-> Building psmouse.ko
make: Entering directory '/usr/lib/modules/4.2.4-1-ARCH/build'
make: *** No rule to make target 'psmouse.ko'. Stop.
make: Leaving directory '/usr/lib/modules/4.2.4-1-ARCH/build'
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build synaptics-led.

vantu5z commented on 2015-10-29 06:30

I think that this driver (1.7.1) not support your touchpad.
Try to apply patch to 1.8.2 and 1.7.99.2, but X don't start with it.
Can run 1.7.6 version. Package updated. May be that help you.

dhemaseka commented on 2015-10-25 23:21

I have latest xorg and kernel.
Laptop : HP 1000-1431tu (it's a notebook, not hp 1000 mini series).
Yes I was using standard synaptics driver before, but I want my touchpad indicator work (it's next to touchpad's top left edge, toggled by double-tapping top left area of touchpad)

vantu5z commented on 2015-10-25 19:09

Please say xorg and kernel versions.
What laptop do you use?
For now you can install standard "xf86-input-synaptics" from repo to make touchpad work.

dhemaseka commented on 2015-10-25 08:43

after installed this my touchpad wont work. "synclient" command said "Couldn't find synaptics properties. No synaptics driver loaded?". How can I fix this? Thanks