Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - wxformbuilder-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: wxformbuilder-git 3.5.2.RC2.rf6dbe4c-1

Git Clone URL: https://aur-dev.archlinux.org/wxformbuilder-git.git (read-only)
Package Base: wxformbuilder-git
Description: Designer, GUI builder, and RAD tool For wxWidgets
Upstream URL: https://sourceforge.net/projects/wxformbuilder/
Keywords: C++ Designer GUI Lua PHP Python RAD wxGtk wxWidgets XRC
Licenses: GPL
Conflicts: wxformbuilder, wxformbuilder-svn
Provides: wxformbuilder
Submitter: jgmdev
Maintainer: jgmdev
Last Packager: jgmdev
Votes: 15
Popularity: 0.978084
First Submitted: 2016-10-03 16:35
Last Updated: 2016-10-03 16:35

Latest Comments

jgmdev commented on 2016-10-03 16:41

wxFormBuilder developers moved all development to GitHub (https://sourceforge.net/p/wxformbuilder/news/2016/09/all-development-has-moved-to-github/), I created the wxformbuilder-git package based on this one. (https://aur.archlinux.org/packages/wxformbuilder-git/)

Maybe this package should be merged now to wxformbuilder-git

orson commented on 2016-04-13 12:02

It requires the following patch to build it against wxWidgets 3.1 (it is backward compatible as well):

--- PKGBUILD 2016-04-13 13:48:53.150005247 +0200
+++ PKGBUILD 2016-04-13 13:52:40.891801514 +0200
@@ -16,7 +16,7 @@ makedepends=('subversion')
source=("wxformbuilder::svn+http://svn.code.sf.net/p/wxformbuilder/code/3.x/trunk")
md5sums=('SKIP')
url="http://wxformbuilder.sourceforge.net/"
-license="GPL"
+license=('GPL')

pkgver() {
cd "${srcdir}/wxformbuilder"
@@ -28,7 +28,7 @@ pkgver() {
build() {
cd "$srcdir/wxformbuilder"
./create_build_files4.sh
- cd build/3.0/gmake
+ cd build/$(wx-config --release)/gmake
make config=release
}

jrborba commented on 2016-02-27 05:49

License in PKGBUILD **MUST** be an array, like this: license=('GPL'). Anyone, it can't compile.

mrbit commented on 2012-04-10 09:34

after make
patch --> wxformbuild/src/Makefile CPPFLAGS no -mswindows

makepkg....