Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - wsjtx-svn

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: wsjtx-svn r7034-1

Git Clone URL: https://aur-dev.archlinux.org/wsjtx-svn.git (read-only)
Package Base: wsjtx-svn
Description: Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)
Upstream URL: http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
Licenses: GPL-3
Conflicts: wsjtx
Provides: wsjtx
Submitter: 7h0ma5
Maintainer: 7h0ma5
Last Packager: 7h0ma5
Votes: 1
Popularity: 0.000037
First Submitted: 2015-06-14 23:16
Last Updated: 2016-08-22 20:31

Latest Comments

hk4adj commented on 2017-01-24 17:43

Hello, it fails to compile and install here:

[ 36%] Building CXX object CMakeFiles/wsjt_qt.dir/HamlibTransceiver.cpp.o
/tmp/yaourt-tmp-a/aur-wsjtx-svn/src/wsjtx/HamlibTransceiver.cpp: In member function ‘virtual int HamlibTransceiver::do_start()’:
/tmp/yaourt-tmp-a/aur-wsjtx-svn/src/wsjtx/HamlibTransceiver.cpp:550:66: error: ‘RIG_PASSBAND_NOCHANGE’ was not declared in this scope
rig_set_mode (rig_.data (), RIG_VFO_CURR, dummy_mode_, RIG_PASSBAND_NOCHANGE);


FOR IT TO COMPILE IS REQUIRED THE USE OF HAMLIB_GIT

^~~~~~~~~~~~~~~~~~~~~
make[2]: *** [CMakeFiles/wsjt_qt.dir/build.make:668: CMakeFiles/wsjt_qt.dir/HamlibTransceiver.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:597: CMakeFiles/wsjt_qt.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build wsjtx-svn.


FOR IT TO COMPILE IS REQUIRED THE USE OF HAMLIB_GIT

nulloranje commented on 2016-08-14 01:41

Get the following error when building with hamlib or hamlib-git:

-- Checking for module 'hamlib'
-- Found hamlib, version 3.1~git
-- Found hamlib
CMake Error at /usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find hamlib (missing: hamlib_LIBRARY_DIRS) (Required is at least
version "3")
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
CMake/Modules/Findhamlib.cmake:81 (find_package_handle_standard_args)
CMakeLists.txt:883 (find_package)

maze commented on 2016-02-14 08:30

Hamlib has been upgraded to 3.x, please test.