Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - wireshark-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: wireshark-git 2.3.0rc0+1510+gc274046-1

Git Clone URL: https://aur-dev.archlinux.org/wireshark-git.git (read-only)
Package Base: wireshark-git
Description: A free network protocol analyzer for Unix/Linux. GIT version
Upstream URL: https://www.wireshark.org/
Licenses: GPL2
Conflicts: wireshark-cli, wireshark-common, wireshark-gtk, wireshark-qt
Provides: wireshark
Replaces: ethereal
Submitter: drevilt
Maintainer: Lekensteyn
Last Packager: Lekensteyn
Votes: 4
Popularity: 0.385843
First Submitted: 2014-07-11 19:05
Last Updated: 2016-11-19 00:16

Latest Comments

1 2 3 4 Next › Last »

Lekensteyn commented on 2016-11-08 17:19

Please try the updated PKGBUILD. I have test-compiled it in a clean VM and compared it to the wireshark-{cli,common,qt} contents and it seems fit.

Lekensteyn commented on 2016-11-08 13:00

I just adopted this package, will update it to use cmake and fix the dependencies.

erikzenker commented on 2016-11-08 12:59

configure: error: Your pcap library is more recent than your pcap header.
As you are building with compiler warnings treated as errors, Wireshark
won't be able to use functions not declared in that header.
If you wish to build with compiler warnings treated as errors, You should
install a newer version of the header file.

Is there some weird configuration?

erikzenker commented on 2016-11-08 12:42

configure: error: I couldn't find lrelease-qt5 or lrelease; make sure it's installed and in your path

Is there a dependency missing ?

Gero commented on 2015-10-19 20:18

I rewrote the PKGBUILD to be as much like the stable wireshark PKGBUILD as possible.
https://github.com/gfokkema/aur-wireshark-git

I also added a fix for a crash which I encountered very often.
You might not want to keep using this fix-voip-player-crash.patch,
but I think the rest of the changes to the PKGBUILD could come in handy ;).

Lekensteyn commented on 2015-10-14 09:36

You need LUA 5.1 or 5.2. LUA 5.3 is not supported due to incompatibility issues in the bitops library.

grimsock commented on 2015-10-14 09:29

I'm getting error: configure: error: Lua support was requested, but is not available. But I have installed Lua. Please, fix it.

Lekensteyn commented on 2015-09-22 14:56

Qt will become the default in the next version of Wireshark (2.0), for that you need qt5-tools. Python 3 is also supported, so no need to force Python 2.

With cmake, the correctly wiretap symlink is created out-of-the-box. Here is an example PKGBUILD I created earlier this year: https://github.com/Lekensteyn/aur/tree/master/wireshark-git

Ghost91 commented on 2015-09-22 12:22

The link to libwiretap must be updated to:

ln -s libwiretap.so.0 libwiretap.so.4

Lekensteyn commented on 2015-03-02 13:36

For faster builds, I can recommend you cmake+ninja. This one is based on the wireshark packages:
https://github.com/Lekensteyn/aur/tree/master/wireshark-git