Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - wine-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: wine-git 1.9.24.r105.g1d3b944-4

Git Clone URL: https://aur-dev.archlinux.org/wine-git.git (read-only)
Package Base: wine-git
Description: A compatibility layer for running Windows programs. GIT version.
Upstream URL: http://www.winehq.com
Licenses: LGPL
Conflicts: bin32-wine, wine, wine-wow64
Provides: bin32-wine=1.9.24.r105.g1d3b944, wine=1.9.24.r105.g1d3b944, wine-wow64=1.9.24.r105.g1d3b944
Replaces: bin32-wine
Submitter: None
Maintainer: sidneycrestani
Last Packager: sidneycrestani
Votes: 78
Popularity: 0.297120
First Submitted: 2007-07-18 16:01
Last Updated: 2016-12-06 00:30

Dependencies (138)

Required by (119)

Sources (2)

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10

Anonymous comment on 2010-07-16 13:58

is the "depends" array supposed to be composed exclusively of packages for x64? they're all prefixed by "bin32", and won't build on my x86 system (as expected). I removed all the bin32 prefixes, and I'm waiting for the build to finish. is 1.2 x64-only? I'm confused. maybe you just forgot to differenciate the depends, but I really don't know, so I'll just post this:

depends=('fontconfig' 'libxxf86dga' 'mesa' 'libxcursor'
'libxrandr' 'libxdamage' 'libldap' 'libxslt'
'lcms' 'mesa' 'libpng>=1.4.0')

intellitech commented on 2010-07-13 17:12

IncredibleLaser - It was commented out, not exactly warranting a PKGBUILD update.

Either way, the package has been updated, with changes made to depends/makedepends/conflicts.

IncredibleLaser commented on 2010-07-04 13:32

There are some issues with your PKGBUILD.
1. Most of your depends are makedepends. Check out the official wine PKGBUILD. Also, your alignment is not very readable.
2. provides=("wine-git=$pkgver" ...) is unnecessary. Better: provides=("wine=1.2") or whichever is the next version of wine.
3. conflicts=(... 'wine-git') is wrong. A package cannot conflict itself.
4. # patch -p1 < ${startdir}/patchfile.diff is commented out, but never use $startdir. Add your patches to the sources array and refer to them as ${srcdir}/patchname later. Also, add "|| return 1" to your patchlines.
5. I don't know if necessary, but have a look at the official PKGBUILD for configure-options.

Noctivivans commented on 2010-06-21 12:55

On Arch x86_64 I got configure error:
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.