Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - weston-eglstream

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: weston-eglstream 1.12.0-2

Git Clone URL: https://aur-dev.archlinux.org/weston-eglstream.git (read-only)
Package Base: weston-eglstream
Description: Reference implementation of a Wayland compositor with EGLStream support
Upstream URL: http://wayland.freedesktop.org
Licenses: MIT
Conflicts: weston
Provides: weston
Submitter: aplattner
Maintainer: aplattner (mvicomoya)
Last Packager: aplattner
Votes: 10
Popularity: 0.759809
First Submitted: 2016-03-23 22:34
Last Updated: 2016-12-12 20:06

Required by (13)

Sources (13)

Latest Comments

1 2 3 Next › Last »

mvicomoya commented on 2016-12-16 19:25

What driver version are you using? I'm aware of kernel interaction issues with 375.20, but they should've been resolved with 375.26.

YAOMTC commented on 2016-12-16 05:04

I realized what I was doing wrong. Got a little further this time before running into another issue: http://paste2.org/yy2z0dWI

EDIT: Could my issue be related to this? https://devtalk.nvidia.com/default/topic/974491/linux/gtx-580-375-10-weston-eglstream-produces-crash-in-kernel/

YAOMTC commented on 2016-12-11 19:15

I realized what I was doing wrong. Got a little further this time before running into another issue: http://paste2.org/yy2z0dWI

Do I need to put mesa in ~/install too? Or what

YAOMTC commented on 2016-12-11 03:52

I haven't installed software like this before, but I tried - I got stuck on some permissions issues. Following these instructions (and getting stuck a few steps in): https://wayland.freedesktop.org/building.html

http://paste2.org/Hsfbta69

http://paste2.org/teKWxPGd

mvicomoya commented on 2016-12-10 01:40

I'll try to get this package updated as soon as possible. In the meantime, can you try with our side weston branch here?

https://cgit.freedesktop.org/~jjones/weston/?h=nvidia_head_rebase_1.11

1.12 branch should work too, but client application using XDG shell v6 won't start.

YAOMTC commented on 2016-12-10 01:28

I couldn't get weston to return any errors. I just can't get it to launch at all.

weston-launch -v -- --use-egl-device > ~/westonfail.txt

After a moment, the text cursor reappears at the top left. I hit enter and I'm back at the command prompt, and the resulting text file is empty. Nothing showed up in the system log either. Using nvidia 375.20-3.

Teknoman117 commented on 2016-10-21 23:26

I can't seem to get EGL/GLESv2 applications working inside the compositor on nvidia driver version 370.28. I get the following error when I try to run weston-simple-egl. The SHM based applications work fine...

weston-simple-egl: clients/simple-egl.c:154: init_egl: Assertion `display->egl.dpy' failed.
[2] 1135 abort (core dumped) weston-simple-egl

shoober420 commented on 2016-09-21 19:03

Thank you for updating the package sir!

StarterX4 commented on 2016-09-10 01:17

Don't works with 367.44:
weston --use-egldevice

Fatal: failed to create compositor backendci0000:00/0000:00:09.0/

shoober420 commented on 2016-06-12 23:46

I finally got it to work. It was because I had sync to Vblank disabled with an environment variable. The setting was this.

__GL_SYNC_TO_VBLANK=0

After changing it to 1, it works. Awesome! Too bad Wayland doesn't have full OpenGL support or else I could be playing Quake right now. Thank you for making and updating this package aplattner.