Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: vogl-git 716.434dcc5-1

Git Clone URL: https://aur-dev.archlinux.org/vogl-git.git (read-only)
Package Base: vogl-git
Description: An OpenGL debugger
Upstream URL: https://github.com/ValveSoftware/vogl
Licenses: MIT
Submitter: stativ
Maintainer: stativ
Last Packager: stativ
Votes: 12
Popularity: 0.001616
First Submitted: 2014-03-13 12:54
Last Updated: 2016-06-11 16:23

Dependencies (9)

Required by (0)

Sources (2)

Latest Comments

1 2 3 Next › Last »

WebFreak commented on 2016-06-04 11:04

makepkg seems to fail to build this:
==> Starting prepare()...
patching file src/vogleditor/vogleditor_qsettings.h
Reversed (or previously applied) patch detected! Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file src/vogleditor/vogleditor_qsettings.h.rej
==> ERROR: A failure occurred in prepare().
Aborting...
==> ERROR: Makepkg was unable to build vogl-git.

stativ commented on 2016-01-20 21:12

lmat: sorry, but I'm not going to do that. First, the PKGBUILD uses the git support from makepkg which doesn't support shallow clones. Second, I'm against using shallow clones myself. It breaks git pull, you can't freely move through the history and you clone the full sources only once anyway. BTW: there has been several discussions about shallow clones on pacman-dev mailing list with reasoning why it won't be implemented.

lmat commented on 2016-01-14 20:40

Is it possible to get this pkgbuild to make a shallow clone (rather than the full history)? Also, is it possible to build recursively? Builds usually go faster than this, but using only one core is slow :-)

stativ commented on 2015-12-23 13:41

thrimbor: thx, fixed.

thrimbor commented on 2015-12-14 16:34

Your prepare() assumes that a global git name&email is set and breaks when that's not the case.

stativ commented on 2015-08-08 15:49

lubosz: thank you, I applied both patches, though I did some minor changes (corrected the "git am" line, merged the patches so the .SRCINFO is correct).

Could you please also send the build fix to upstream, too? There was not much activity in the upstream repository lately, but they used to merge small fixes pretty quickly in the past.

lubosz commented on 2015-07-27 13:58

I have two patches of interest

fix build with Qt 5.5:
https://gist.github.com/lubosz/f336ad3096260b98633e

fix bash syntax for mksrcinfo. update .SRCINFO:
https://gist.github.com/lubosz/6a1b0199313ffb9533ef

cguenther commented on 2014-08-04 11:40

The current version does not finde the following file:
src/cmake/Modules/FindQt5.cmake

Removing the Qt version check from the package build seems to fix the problem for me.

ahuillet commented on 2014-06-19 11:48

Confirmed fixed. Thank you!

stativ commented on 2014-06-19 10:49

Fixed.

I've changed the PKGBUILD to install everything into /opt to avoid patching the sources. Before it was necessary to patch vogl in any case to make it work, but now that it works without any patches it's better to avoid the patches altogether to make it less error prone.