Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - vlc-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: vlc-git 3.0.0.r10950.gfaa5a38a4c-1

Git Clone URL: https://aur-dev.archlinux.org/vlc-git.git (read-only)
Package Base: vlc-git
Description: A multi-platform MPEG, VCD/DVD, and DivX player (GIT Version)
Upstream URL: http://www.videolan.org/vlc/
Licenses: GPLv3, LGPLv2.1
Conflicts: vlc, vlc-dev, vlc-plugin, vlc-stable-git
Provides: vlc=3.0.0.r10950.gfaa5a38a4c
Submitter: None
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 172
Popularity: 2.665262
First Submitted: 2008-04-01 12:14
Last Updated: 2017-02-03 14:43

Dependencies (76)

Required by (91)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

WorMzy commented on 2017-02-04 01:07

Currently fails to build with the following error:

checking for the Wayland protocols... not found
Package wayland-protocols was not found in the pkg-config search path.
Perhaps you should add the directory containing `wayland-protocols.pc'
to the PKG_CONFIG_PATH environment variable

Fixed by adding wayland-protocols to the makedepends array.

Namcap also suggests that qt5-base should be a dependency, rather than just a makedep. It also says that libarchive, libsecret, and hicolor-icon-theme should be added as dependencies.

The backup array is unnecessary as neither file is provided by the package, and most of the .install file is handled by pacman hooks, so those lines can be removed from it.

I'd also like to request that qt5-x11extras be added to the dependencies, as the qt gui doesn't work if compiled without this package.

andrewSC commented on 2017-02-01 16:11

agapito: touché, I've removed it from the makedeps. Thanks for the comment!

agapito commented on 2017-02-01 05:44

kdelibs should be dropped from makedepends; is not needed to build this package.

andrewSC commented on 2017-01-31 14:48

FredBezies, soloturn: I've updated the PKGBUILD to reflect the gnome-vfs removal, also bumped RCC to use qt5 since that's what's being specified in makedeps. Thanks for pointing this stuff out!

FredBezies commented on 2017-01-30 12:25

Gnome-vfs was depreciated with gstreamer0.10 and some other packages.

See : https://lists.archlinux.org/pipermail/arch-dev-public/2017-January/028639.html

Another point : replacing RCC=/usr/bin/rcc-qt4 by RCC=/usr/bin/rcc-qt5 is possible, or not?

soloturn commented on 2017-01-29 08:02

the PKGBUILD contains dependency gnome-vfs. is this still true? i only can find gvfs?

andrewSC commented on 2017-01-23 16:28

belst: Thanks for the interesting find :) After doing some digging and testing, I found out you *can* build this with clang however, the error (I believe) you're seeing is related to an ABI issue with libebml. If you've built libebml using gcc/g++ you'll need to rebuild it with clang. Once you've completed this step using clang to build vlc shouldn't be an issue. Let me know if this fixes the problem for you! Thanks!

belst commented on 2017-01-21 08:39

could u add

```
export CC=gcc
export CXX=g++
```

to the build step? The build fails when those set to clang/clang++

andrewSC commented on 2017-01-03 15:46

nsvir: Thanks for the comment. Given that this package is built using latest upstream at all times, sometimes upstream is broken. I've successfully built and updated this package version.

nsvir commented on 2016-12-25 20:42

I have a compilation error:
"codec/avcodec/video.c:840:19: error: implicit declaration of function ‘avcodec_send_packet’ [-Werror=implicit-function-declaration]"

Does a library is missing or something ?