Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - vertcoin-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: vertcoin-git 0.9.0.1-1

Git Clone URL: https://aur-dev.archlinux.org/vertcoin-git.git (read-only)
Package Base: vertcoin-git
Description: Peer-to-peer network based digital currency (includes both the qtclient and the headless daemon)
Upstream URL: http://www.vertcoin.org/
Licenses: MIT
Conflicts: vertcoin
Provides: vertcoin
Submitter: lothar_m
Maintainer: lothar_m
Last Packager: lothar_m
Votes: 3
Popularity: 0.000090
First Submitted: 2014-02-05 12:21
Last Updated: 2015-06-11 14:57

Dependencies (10)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

shackra commented on 2016-09-07 18:35

It should be:

qmake-qt4 USE_QRCODE=1 USE_UPNP=1 vertcoin-qt.pro

shackra commented on 2015-05-23 18:59

well, I got an error while compiling:

/usr/include/boost/variant/get.hpp: In instantiation of 'typename boost::add_reference<T>::type boost::strict_get(boost::variant<T0, TN ...>&) [with U = const CScriptID&; T0 = CNoDestination; TN = {CKeyID, CScriptID}; typename boost::add_reference<T>::type = const CScriptID&]':
/usr/include/boost/variant/get.hpp:284:33: required from 'typename boost::add_reference<T>::type boost::get(boost::variant<T0, TN ...>&) [with U = const CScriptID&; T0 = CNoDestination; TN = {CKeyID, CScriptID}; typename boost::add_reference<T>::type = const CScriptID&]'
src/rpcrawtransaction.cpp:242:77: required from here
/usr/include/boost/variant/get.hpp:212:5: error: static assertion failed: boost::variant does not contain specified type U, call to boost::get<U>(boost::variant<T...>&) will always throw boost::bad_get exception
BOOST_STATIC_ASSERT_MSG(
^
Makefile:2199: recipe for target 'build/rpcrawtransaction.o' failed
make: *** [build/rpcrawtransaction.o] Error 1

I don't know if this is something that upstream can fix.

lothar_m commented on 2015-01-31 10:04

Updated to version 0.9.0.1
Removed the tag section of the git command for simplicity.

ArchMagic commented on 2015-01-30 04:20

You can remove #tag=v0n.n.n from the source line in the PKGBUILD altogether if you're having errors during build.

csolisr commented on 2015-01-10 18:05

Vertcoin has upgraded to version 0.9.0.1, please update the PKGBUILD replacing the relevant version number (currently 0.8.7.3) in the source line, from

source=("$_gitname::git+https://github.com/vertcoin/vertcoin#tag=v0.8.7.3"

to

source=("$_gitname::git+https://github.com/vertcoin/vertcoin#tag=v0.9.0.1"

csolisr commented on 2015-01-10 18:04

Vertcoin has upgraded to version 0.9.0.1, please update the PKGBUILD replacing the relevant version number (currently 0.8.7.3) in the source line.

lothar_m commented on 2014-12-20 14:08

You're right regarding secp256k1. Updated the PKGBUILD.

ArchMagic commented on 2014-12-02 01:40

Addendum to the previous comment; vertcoin-qt will only built AND launch if the AUR package of secp256k1-git is used.

ArchMagic commented on 2014-12-02 01:33

Current git files will not build without secp256k1 installed, so it should be added to the dependencies.
One can install from AUR https://aur.archlinux.org/packages/secp256k1-git/
Or from git:
git clone https://github.com/bitcoin/secp256k1.git
cd secp256k1
./autogen.sh
./configure
make
make install

lothar_m commented on 2014-05-21 19:49

@earlz:
It seems to me that the error you describe is not PKGBUILD related but a bug in the application code, therefor i suggest you file a bug report upstream (if you still get the error of course).