Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: uuid 1.6.2-13

Git Clone URL: https://aur-dev.archlinux.org/uuid.git (read-only)
Package Base: uuid
Description: OSSP Universally Unique Identifier
Upstream URL: http://www.ossp.org/pkg/lib/uuid
Licenses: MIT
Submitter: ilpianista
Maintainer: Black_Codec
Last Packager: Black_Codec
Votes: 66
Popularity: 1.177870
First Submitted: 2012-12-08 17:37
Last Updated: 2017-01-31 22:53

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

vwyodajl commented on 2012-12-10 19:32

@mrbit crap thanks I commented that out to test something else and forgot to uncomment. Thanks for the catch will push the change through :)

mrbit commented on 2012-12-10 19:30

solved with decomment #patch in PKGBUILD !!

vwyodajl commented on 2012-12-10 18:58

@mrbit sorry to say not sure at this point why that is coming up for you. It did not occur for me on any of the boxes I did the change from -9 to -10. Of course I have util-linux installed on the boxes as well.

mrbit commented on 2012-12-10 18:52

pacman -Ql util-linux :

util-linux /usr/lib/libblkid.a
util-linux /usr/lib/libblkid.so
util-linux /usr/lib/libblkid.so.1
util-linux /usr/lib/libblkid.so.1.1.0
util-linux /usr/lib/libmount.a
util-linux /usr/lib/libmount.so
util-linux /usr/lib/libmount.so.1
util-linux /usr/lib/libmount.so.1.1.0
util-linux /usr/lib/libuuid.a
util-linux /usr/lib/libuuid.so
util-linux /usr/lib/libuuid.so.1
util-linux /usr/lib/libuuid.so.1.3.0
util-linux /usr/lib/pkgconfig/

vwyodajl commented on 2012-12-10 18:49

@mrbit I do not know why there would be a conflict with util-linux. Is there more of an error message? util-linux does not even seem to require anything relating to uuid (could be wrong) but not sure how uuid conflicts with util-linux.

vwyodajl commented on 2012-12-10 18:46

Hmm I will dig into this more then and see if I can work up a better solution.

As a temp workaround if you need to use this package, just remove the package, then remove each of those files then reinstall uuid and it should all go fine again. I just hit this on a test box as well. Sorry for the temporary hassle

mrbit commented on 2012-12-10 18:45

pacman -Rdd uuid && packer -S uuid

idem, no install for conflict with util-linux 2.22.1-3 ????

vwyodajl commented on 2012-12-10 18:34

Hmm I will dig into this more then and see if I can work up a better solution.

As a temp workaround if you need to use this package, just remove the package, then remove each of those files then reinstall uuid and it should all go fine again. I just hit this on a test box as well. Sorry for the temporary hassle

richli commented on 2012-12-10 18:30

I had the same error as mrbit. I used "pacman -Rdd uuid" as vwyodajl suggested and tried reinstalling it. Still didn't work. Here's more of the error output:

error: failed to commit transaction (conflicting files)
uuid: /usr/lib/libuuid.a exists in filesystem
uuid: /usr/lib/libuuid.so exists in filesystem
uuid: /usr/lib/pkgconfig/uuid.pc exists in filesystem
uuid: /usr/share/man/man3/uuid.3.gz exists in filesystem
Errors occurred, no packages were upgraded.

vwyodajl commented on 2012-12-10 17:41

pacman -Rdd uuid && packer -S uuid. For some reason i had to do the same with mine when I added back in the perl parts to the build. Just quick uninstall then reinstall and all should be kosher for you again. Was weird I had three boxes that did not complain and 1 that did just like that.

Let me know if that does not work for you and I will dig deeper.