Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - utopia-documents

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: utopia-documents 2.4.4-1

Git Clone URL: https://aur-dev.archlinux.org/utopia-documents.git (read-only)
Package Base: utopia-documents
Description: PDF reader that displays interactive annotations on scientific articles.
Upstream URL: http://utopiadocs.cs.man.ac.uk
Licenses: GPL
Provides: utopia-documents
Submitter: Snow
Maintainer: Snow
Last Packager: Snow
Votes: 1
Popularity: 0.774994
First Submitted: 2014-07-27 16:16
Last Updated: 2015-07-06 18:44

Latest Comments

1 2 Next › Last »

tdy commented on 2017-01-23 07:05

PKGBUILD for utopia-documents-3.0.0. Feel free to take and finalize it:

https://gist.github.com/tdy/b337cdd8d8e01ea6acd8425529171eeb

tcuc commented on 2016-11-30 20:49

i get a similar error:

-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:116 (find_package):
By not providing "Findlxqt-build-tools.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"lxqt-build-tools", but CMake did not find one.

Could not find a package configuration file provided by "lxqt-build-tools"
(requested version 0.1.0) with any of the following names:

lxqt-build-toolsConfig.cmake
lxqt-build-tools-config.cmake

Add the installation prefix of "lxqt-build-tools" to CMAKE_PREFIX_PATH or
set "lxqt-build-tools_DIR" to a directory containing one of the above
files. If "lxqt-build-tools" provides a separate development package or
SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/packerbuild-1000/liblxqt-git/liblxqt-git/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
The build failed.
Dependencies for `utopia-documents' are not met, not building...

lugarparaler commented on 2016-03-12 17:21

Hi!

I get this error message:

[ 47%] Built target athenaeum
[ 47%] Generating moc_documentview_p.cxx
usr/include/boost/type_traits/detail/has_binary_operator.hp:50: Parse error at "BOOST_JOIN"
libpapyro/papyro/CMakeFiles/papyro.dir/build.make:137: recipe for target 'libpapyro/papyro/moc_documentview_p.cxx' failed
make[2]: *** [libpapyro/papyro/moc_documentview_p.cxx] Error 1
CMakeFiles/Makefile2:2152: recipe for target 'libpapyro/papyro/CMakeFiles/papyro.dir/all' failed
make[1]: *** [libpapyro/papyro/CMakeFiles/papyro.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Snow commented on 2014-11-18 23:01

Updated Version
Some tricks to resolve compling problem and libs linking problem.


Please feel free to inform me about any trouble on this PKGBUILD.

Snow commented on 2014-11-08 00:34

@strugk, Thank you. Updated.

About other problems(version updating libs linking and compile errors) I will do two months later, about when I have finished my PhD application.
During this two months, if you find any missing packages. Please mention me and I will add it to dependence soon.

strugk commented on 2014-11-07 17:16

qjson is one missing dependency as i noticed...

xganesh commented on 2014-10-09 04:23

@Snow, I have qt4 4.8.6-1 installed.
I tried again, and got the same error :(

Snow commented on 2014-10-03 00:21

@xganesh I guess I know what causes the problem. Have you installed qt4?

I find that I forgot to add qt4 to the dependence list.

Snow commented on 2014-10-03 00:21

@xganesh I guess I know what causes the problem. Have you installed qt4?

xganesh commented on 2014-09-11 02:08

By the way:
Same errors occur when downloading the PKGBUILD and compiling using 'makepkg'.