Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - upsource

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: upsource 2.5-1

Git Clone URL: https://aur-dev.archlinux.org/upsource.git (read-only)
Package Base: upsource
Description: Repository Browsing and Code Review tool from JetBrains
Upstream URL: https://www.jetbrains.com/upsource/
Licenses: Commercial
Submitter: windy
Maintainer: None
Last Packager: windy
Votes: 3
Popularity: 0.000037
First Submitted: 2014-12-23 14:23
Last Updated: 2015-11-22 13:47

Latest Comments

intgr commented on 2015-11-23 08:44

This package needs a rewrite to conform to Linux best practices: state data, like databases and service-writable configuration, should be kept in /var/lib/upsource; log files in /var/log/upsource; the /opt/upsource directory should not be writable to the service itself.

windy commented on 2015-11-22 13:48

WARNING!

Upgrading from v2.0 to v2.5 is not supported directly. You have to create a backup with v2.0 before updating the package and import the backup into v2.5.

Please see http://www.jetbrains.com/upsource/help/2.5/upgrade.html for details.

windy commented on 2015-08-29 18:54

The latest version (2.0.3653) does not start, even with a fresh install. I submitted a bugreport to JetBrains and waiting for a reply.

https://youtrack.jetbrains.com/issue/UP-5058

Any help with this is appreciated, the diff for the PKGBUILD is:

-pkgver=2.0.3554
+pkgver=2.0.3653

-sha256sums=('04248791720e49d0ade4397cd45eca7cd5b1ce09f32e195583ba99e9aa0be70d'
+sha256sums=('c7807151e985bb87eadf88cc0de282d640fbb88158df5e46d936189f8007d3ed'

windy commented on 2015-05-21 19:43

WARNING!

Upgrading from v1.0 to v2.0 is not supported directly. You have to create a backup with v1.0 before updating the package and import the backup into v2.0. It is also required to update the license manually if you use the free license.

https://youtrack.jetbrains.com/issue/UP-4067
https://youtrack.jetbrains.com/issue/UP-4068

windy commented on 2015-04-17 17:27

@FTC56: I have no intention to package EAP builds, so you are free to go. :)

Kendos_Kenlen commented on 2015-04-16 23:08

An EAP is available if you want to maintain its package. Otherwise, I'll do it ! :)

windy commented on 2015-02-10 20:06

Thanks for the hint, I will change this when the next version is available.

Kendos_Kenlen commented on 2015-02-10 11:15

Hi,

Maybe it could be better to use the version number when available (like 1.0.1 now) instead of the build number when it's possible ?

During EAP, use the build number is more clear, but for normal releases, it's a little bit more hard to know if it's the current build...