Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - update-hosts-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: update-hosts-git r279.f5df42d-1

Git Clone URL: https://aur-dev.archlinux.org/update-hosts-git.git (read-only)
Package Base: update-hosts-git
Description: Generate a hosts file based on multiple sources (git)
Upstream URL: https://github.com/pyamsoft/update-hosts.git
Licenses: MIT
Conflicts: update-hosts
Provides: update-hosts
Submitter: pyamsoft
Maintainer: pyamsoft
Last Packager: pyamsoft
Votes: 1
Popularity: 0.312619
First Submitted: 2015-09-12 05:29
Last Updated: 2017-01-11 22:46

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

sekret commented on 2016-02-06 11:44

Please change the arch line to

arch=('any')

because there are no binaries in this package!



Furthermore you need to add the license to the package. To do this, please add this line to the package() function:

install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"



One last thing: All the dependencies you list in the depends line are in the base group, therefore they don't have to be included as a dependency, because every Arch user is supposed to have this group installed! :)