Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ttf-ms-fonts 2.0-10

Git Clone URL: https://aur-dev.archlinux.org/ttf-ms-fonts.git (read-only)
Package Base: ttf-ms-fonts
Description: Core TTF Fonts from Microsoft
Upstream URL: http://corefonts.sourceforge.net/
Keywords: corefonts
Licenses: custom:microsoft
Provides: ttf-font
Submitter: None
Maintainer: birdflesh
Last Packager: birdflesh
Votes: 1764
Popularity: 17.965109
First Submitted: 2010-12-01 11:17
Last Updated: 2015-06-09 16:50

Required by (98)

Sources (11)

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 Next › Last »

birdflesh commented on 2011-01-15 21:06

You should probably contact clyde's developer about this. Adding workarounds for specific AUR helpers, while the PKGBUILD normally builds fine, is something that shouldn't be necessary. Thanks for letting us know though.

Anonymous comment on 2011-01-15 20:43

Sorry, but RamsesDeNorre is right. The latest iteration won't build for me, either, unless I make the alteration he suggested.

Upon further investigation, the reason is probably because in previous iterations you had a step that provided a setup.exe. I noticed that I had two package versions in the same location, suggesting that the cached data wasn't cleaned between version builds. Deleting the build directory had the same effect as RamsesDeNorre's change, allowing me to build.

I'm using clyde for installing packages. I'm not sure if other package managers would have the same issue with caching package data.

Anonymous comment on 2011-01-13 14:03

Ok, according to the name ttf-ms-extrafonts is supposed to be a nice addition to this package here. But it should include way more fonts imho.

You know what? I think it's better if one of you guys takes the package. I created it because its removal from the repos was discussed on the mailing lists and I wanted to help, but I don't need it as much as you guys do.
I suggest, whoever takes this package here should also adopt ttf-ms-extrafonts to make them a nice couple.

Last note for RamsesDeNorre, I really don't understand why you need this. There's no setup.exe in the srcdir!

Anonymous comment on 2011-01-12 18:50

I had to add a

if [ "${font}" != "${srcdir}/setup.exe" ]; then
cabextract stuff
fi

around the cabextract line to avoid getting

/tmp/clyde-ramses/ttf-ms-fonts/ttf-ms-fonts/src/setup.exe: no valid cabinets found

After doing so the package built fine.

Jonhoo commented on 2011-01-12 17:01

Hmm..
Just had a look around, and we already have two other ms fonts packages:
http://aur.archlinux.org/packages.php?ID=35297
http://aur.archlinux.org/packages.php?ID=10408

Maybe find a way of sorting out this mess and providing two or three coordinated packages instead?

Anonymous comment on 2011-01-12 16:55

That's a good suggestion too. I guess I'll leave this package as it is now and add one called ttf-ms-fonts-extra with additional fonts. Does anybody know where I can find a list of additional fonts for this other package?

Anonymous comment on 2011-01-12 16:43

As of 2.0-7 it is working fine. Maybe you can keep this package as it is (it's working nicely) and add a new package with additional fonts that are not part of corefonts (as tahoma) for people who want them. Thanks for your work.

Anonymous comment on 2011-01-12 12:41

Ok guys, I switched back to the initial fonts, so tahoma is removed for now. I'll give Jonhoo's suggestion another thought and will bring an update soon.

Anonymous comment on 2011-01-12 12:00

I have the same problem as Vieira, /usr/share/fonts/TTF/tahomabd.ttf is missing.

Anonymous comment on 2011-01-12 01:38

Hello,
I'm having some problems (ugly fonts) on some websites (for e.g. www.sapo.pt) after updating from 2.0-5 to 2.0-6. I downgraded and everything looks nice again.
Do you have any idea of which changes lead to this problem? Is it related to the removal of tahoma?
Thanks in advance.