Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: torrentv-git r61.0804fa8-1

Git Clone URL: https://aur-dev.archlinux.org/torrentv-git.git (read-only)
Package Base: torrentv-git
Description: Stream Torrents to your AppleTV/Roku/Chromecast
Upstream URL: http://torrentv.github.io/
Licenses: GPL3
Conflicts: torrentv
Provides: torrentv
Submitter: M0Rf30
Maintainer: None
Last Packager: M0Rf30
Votes: 2
Popularity: 0.000545
First Submitted: 2014-09-09 16:12
Last Updated: 2015-12-29 13:34

Latest Comments

sergey.orloff commented on 2016-12-16 07:10

Hello, please help to understand what was going on, and how to install the package?

TorrenTV@0.9.10 /build/torrentv-git/src/torrentv
└─┬ UNMET PEER DEPENDENCY grunt@1.0.1
├── coffee-script@1.10.0
├── dateformat@1.0.12
├── eventemitter2@0.4.14
├── exit@0.1.2
├─┬ findup-sync@0.3.0
│ └── glob@5.0.15
├── glob@7.0.6
├─┬ grunt-cli@1.2.0
│ └── resolve@1.1.7
├── grunt-known-options@1.1.0
├─┬ grunt-legacy-log@1.0.0
│ ├── colors@1.1.2
│ ├─┬ grunt-legacy-log-utils@1.0.0
│ │ └── lodash@4.3.0
│ ├── hooker@0.2.3
│ ├── lodash@3.10.1
│ └── underscore.string@3.2.3
├─┬ grunt-legacy-util@1.0.0
│ ├── async@1.5.2
│ ├── getobject@0.1.0
│ ├── lodash@4.3.0
│ └─┬ which@1.2.12
│ └── isexe@1.1.2
├─┬ js-yaml@3.5.5
│ ├─┬ argparse@1.0.9
│ │ └── sprintf-js@1.0.3
│ └── esprima@2.7.3
├── minimatch@3.0.3
├─┬ nopt@3.0.6
│ └── abbrev@1.0.9
└── rimraf@2.2.8

npm WARN enoent ENOENT: no such file or directory, open '/build/torrentv-git/src/torrentv/node_modules/chromecast-js/package.json'
npm WARN grunt-contrib-clean@0.5.0 requires a peer of grunt@~0.4.0 but none was installed.
npm WARN grunt-contrib-compress@0.10.0 requires a peer of grunt@~0.4.0 but none was installed.
npm WARN grunt-node-webkit-builder@0.1.21 requires a peer of grunt@~0.4.2 but none was installed.
npm WARN TorrenTV@0.9.10 No repository field.
==> ОШИБКА: Произошел сбой в prepare().
Прерывание...
[sergey@p43es3g torrentv-git]$

andriesinfoserv commented on 2016-01-06 00:09

@M0Rf30
builds fine now, thanks.

andriesinfoserv commented on 2015-12-28 17:41

after changing nodejs-bower to bower in PKGBUILD and installing npm manually via pacman(seems it wasn't pulled in as dependency of nodejs-cli or bower for some reason), this still fails to build with "Fatal error: Unable to find local grunt." I also ran "npm install -g grunt-cli" and "npm install -g grunt" for good measure.

Thanks in advance.

hobarrera commented on 2015-10-09 07:18

makedepends should list "bower" (which is in now in [community]).