Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - swift-bin

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: swift-bin 3.0.1-3

Git Clone URL: https://aur-dev.archlinux.org/swift-bin.git (read-only)
Package Base: swift-bin
Description: Official binary builds of the Swift programming language.
Upstream URL: https://swift.org
Keywords: apple language swift swiftlang
Licenses: Apache
Conflicts: lldb, swift-language-git
Provides: swift-language
Replaces: swift-language-bin
Submitter: ashleyis
Maintainer: KamranMackey
Last Packager: KamranMackey
Votes: 38
Popularity: 0.518741
First Submitted: 2015-12-04 17:31
Last Updated: 2016-11-09 03:11

Latest Comments

1 2 3 4 Next › Last »

SuhairZain commented on 2016-12-19 13:15

@tarasis
What worked for me was to skip the PGP check. I did it this way:
yaourt --m-arg "--skippgpcheck" -Sb ncurses5-compat-libs

tarasis commented on 2016-12-06 14:48

Fails to build because "libtinfo5" is not available:

==> swift-bin dependencies:
- libedit (already installed)
- python2 (already installed)
- libutil-linux (already installed)
- libbsd (already installed)
- python2-six (already installed)
- libxml2 (already installed)
- icu55 (building from AUR)
- ncurses5-compat-libs (building from AUR)
- clang (package found)
- libtinfo5 (building from AUR)

==> Continue building swift-bin ? [Y/n]
==> -----------------------------------
==> y

==> Building and installing package
==> Install or build missing dependencies for swift-bin:
error: target not found: libtinfo5

and trying to build ncurses5-compat-libs results in:

==> Validating source files with md5sums...
ncurses-6.0.tar.gz ... Passed
ncurses-6.0.tar.gz.sig ... Skipped
==> Verifying source file signatures with gpg...
ncurses-6.0.tar.gz ... FAILED (error during signature verification)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build ncurses5-compat-libs.

beej commented on 2016-10-15 22:06

Anyone have a working PKGBUILD for 3.0, by any chance?

roadev commented on 2016-06-12 19:36

I'm getting this error:

C++ apps may want to build with CXXFLAGS = --std=c++0x
rebuilding config/icucross.mk
rebuilding config/icucross.inc
cd ./config; \
make -f pkgdataMakefile
make[1]: Entering directory '/tmp/yaourt-tmp-jroa/aur-icu55/src/icu/source/config'
rm -rf pkgdata.inc
make[1]: Leaving directory '/tmp/yaourt-tmp-jroa/aur-icu55/src/icu/source/config'
rm -rf config/icu-config
0 ./config/icu-config-top config/icu-config
make: 0: Command not found
Makefile:331: recipe for target 'config/icu-config' failed
make: *** [config/icu-config] Error 127
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build icu55.
==> Restart building icu55 ? [y/N]

luzvioleta commented on 2016-06-02 18:40

@archshift → Well, that would be a problem because of what's mentioned in here → https://swift.org/lldb/

archshift commented on 2016-05-26 20:26

Can this either provide or not include lldb? Otherwise a user wouldn't be able to install any packages which depend on lldb.

luzvioleta commented on 2016-05-26 13:05

@hav3lock → Updated, thank you for the notice <3

hav3lock commented on 2016-05-24 22:31

libtinfo-5 will be now called libtinfo5, please update your package accordingly.

luzvioleta commented on 2016-05-23 19:38

@jahiy → For the GPG error to go away, you have to import that key. See official site ( https://swift.org/ ), scrolling down the "using downloads" which has notes for signing.

IMHO it's redundant to have both PGP and SHA256sum (that's how the PKGBUILD already was when I got it), ¿any opinions/preferences on this?

jahiy commented on 2016-05-23 14:42

$ makepkg -sci
==> Making package: swift-bin 2.2.1-3 (Mon May 23 22:25:42 HKT 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found swift-2.2.1-RELEASE-ubuntu15.10.tar.gz
-> Found swift-2.2.1-RELEASE-ubuntu15.10.tar.gz.sig
==> Validating source files with sha256sums...
swift-2.2.1-RELEASE-ubuntu15.10.tar.gz ... Passed
swift-2.2.1-RELEASE-ubuntu15.10.tar.gz.sig ... Skipped
==> Verifying source file signatures with gpg...
swift-2.2.1-RELEASE-ubuntu15.10.tar.gz ... FAILED (unknown public key 9F597F4D21A56D5F)
==> ERROR: One or more PGP signatures could not be verified!

So, what's wrong?