Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - svg2tikz-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: svg2tikz-git r203.d138c81-1

Git Clone URL: https://aur-dev.archlinux.org/svg2tikz-git.git (read-only)
Package Base: svg2tikz-git
Description: set of tools for converting SVG graphics to TikZ/PGF code
Upstream URL: https://github.com/kjellmf/svg2tikz
Licenses: GPL
Conflicts: inkscape-tikz
Provides: inkscape-tikz
Replaces: inkscape-tikz-hg
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 14
Popularity: 0.000516
First Submitted: 2014-08-23 13:27
Last Updated: 2015-07-28 16:33

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

haawda commented on 2015-05-14 10:35

Thanks, I implemented your sugeestions in a similar way.

giniu commented on 2015-05-14 06:56

Hi there!

I believe two things can be improved with this PKGBUILD:

1) There is new recommended versioning (see /usr/share/pacman/PKGBUILD-vcs.proto)

2) /usr/share/inkscape/extensions is missing (with files tikz_export_effect.inx and tikz_export_output.inx which are nowhere installed by setup.py)

Modified PKGBUILD is here: http://pastebin.com/S8ejJc8B

Thanks for maintaining this!

Mikaye commented on 2014-08-22 08:21

Now the project uses git (https://github.com/kjellmf/svg2tikz)

crabman commented on 2013-05-24 14:34

please add python2-lxml to the list of dependencies.

haawda commented on 2013-04-06 20:20

pacman-4.1-ready PKGBUILD

haawda commented on 2012-11-30 22:09

Hm, the name is misleading then. But you are right.

giniu commented on 2012-11-30 13:29

btw, I believe that inkscape is optdepend? Because this has command line version that works just as well without inkscape iirc.

giniu commented on 2012-07-16 11:10

python2-lxml is a dependency for this, without it I'm getting:

The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension. Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml