Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - spek-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: spek-git 0.8.3.r98.g5b24d78-1

Git Clone URL: https://aur-dev.archlinux.org/spek-git.git (read-only)
Package Base: spek-git
Description: Spek helps to analyse your audio files by showing their spectrogram.
Upstream URL: http://www.spek-project.org/
Licenses: GPL
Conflicts: spek
Provides: spek-git
Submitter: sen
Maintainer: TheNiceGuy
Last Packager: TheNiceGuy
Votes: 5
Popularity: 0.113985
First Submitted: 2010-05-17 19:36
Last Updated: 2016-09-29 12:26

Latest Comments

« First ‹ Previous 1 2

Anonymous comment on 2010-05-18 22:57

Works now, thanks you!

sen commented on 2010-05-18 16:30

Yeah just read about it on the wiki page for gnome packages: http://wiki.archlinux.org/index.php/Gnome_package_guidelines#GTK_Icon_cache

The icon cache will now be updated after an install/update. ;)

Anonymous comment on 2010-05-18 15:28

That did the trick, thanks!

Actually the icon cache is updated during `make install` but because it's installed into $pkgdir, the icons cannot be found after the package is installed into /usr.

I checked how for example Totem is packaged, it forces the update in the .install file, I guess Spek needs something similar: http://repos.archlinux.org/wsvn/packages/totem/repos/extra-x86_64/totem.install

sen commented on 2010-05-18 15:14

Ok, updated.

You could try to forcefully update the icon cache: gtk-update-icon-cache -f /usr/share/icons/hicolor

Anonymous comment on 2010-05-18 14:51

Thanks for updating it!

I'm seeing the same list here, but the icon is still missing. I'll check this later.

As for taking over the package, I'd rather someone else does the packaging, I don't know much about it.

By the way, `vala` should be in makedepends instead of depends. It's not really needed to run spek. Actually, it's not even needed to compile spek from the tarball, but only when building from git.

sen commented on 2010-05-18 13:54

Thanks, I've updated the dependencies!
I'm not sure about the icon glitch but I've just installed the updated package and the icons are working fine here.

# pacman -Ql spek-git
spek-git /usr/
spek-git /usr/bin/
spek-git /usr/bin/spek
spek-git /usr/share/
spek-git /usr/share/applications/
spek-git /usr/share/applications/spek.desktop
spek-git /usr/share/icons/
spek-git /usr/share/icons/hicolor/
spek-git /usr/share/icons/hicolor/16x16/
spek-git /usr/share/icons/hicolor/16x16/apps/
spek-git /usr/share/icons/hicolor/16x16/apps/spek.png
spek-git /usr/share/icons/hicolor/22x22/
spek-git /usr/share/icons/hicolor/22x22/apps/
spek-git /usr/share/icons/hicolor/22x22/apps/spek.png
spek-git /usr/share/icons/hicolor/24x24/
spek-git /usr/share/icons/hicolor/24x24/apps/
spek-git /usr/share/icons/hicolor/24x24/apps/spek.png
spek-git /usr/share/icons/hicolor/32x32/
spek-git /usr/share/icons/hicolor/32x32/apps/
spek-git /usr/share/icons/hicolor/32x32/apps/spek.png
spek-git /usr/share/icons/hicolor/48x48/
spek-git /usr/share/icons/hicolor/48x48/apps/
spek-git /usr/share/icons/hicolor/48x48/apps/spek.png
spek-git /usr/share/icons/hicolor/scalable/
spek-git /usr/share/icons/hicolor/scalable/apps/
spek-git /usr/share/icons/hicolor/scalable/apps/spek.svg

I didn't know that you are also an arch user. Do you want to take over this package since its your program?

Anonymous comment on 2010-05-18 11:21

Speaking of dependencies, spek also needs `gstreamer0.10-base-plugins` and `gstreamer0.10-good-plugins` at runtime.

Anonymous comment on 2010-05-18 04:44

You also need to add 'vala' to makedepends.

Anonymous comment on 2010-05-17 23:33

Thank you sen, works wonders!

I noticed a small glitch. When making and installing manually with `./autogen.sh --prefix=/usr && make && sudo make install` the icon in the About dialogue and in the Applications / Sound & Video menu show up fine. However when installing from AUR, the icons are broken.

Any ideas why this could happen?