Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - spectrum2

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: spectrum2 2.0.3-4

Git Clone URL: https://aur-dev.archlinux.org/spectrum2.git (read-only)
Package Base: spectrum2
Description: Create C++ transports easily
Upstream URL: http://spectrum.im
Licenses: GPL
Submitter: moyamo
Maintainer: moyamo
Last Packager: moyamo
Votes: 3
Popularity: 0.009973
First Submitted: 2016-01-22 14:52
Last Updated: 2016-11-28 21:03

Dependencies (30)

Required by (0)

Sources (2)

Latest Comments

moyamo commented on 2016-11-28 21:06

I'm not sure. swift and libcommuni are separate projects. They are both available on the AUR you can try building them on an ARM device. Just add 'armv7h' to the 'arch=(...)'.

budkin commented on 2016-11-26 02:21

==> ERROR: swift is not available for the 'armv7h' architecture.
==> ERROR: libcommuni is not available for the 'armv7h' architecture.

is it, really?

syntobu commented on 2016-08-30 07:30

This should also depend on libevent. Without it, spectrum fails to build.

fanningert commented on 2016-07-21 16:17

I changed the PKGBUILD and add one file.
* ANY arch for ARM support
* Moved some depends to optional depends
* Add systemd service for spectrum2

https://github.com/fanningert/PKGBUILDs/tree/master/aur/spectrum2