Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - sonic-pi

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: sonic-pi 2.11.1-1

Git Clone URL: https://aur-dev.archlinux.org/sonic-pi.git (read-only)
Package Base: sonic-pi
Description: A music-centric programming environment, originally built for the raspberry pi.
Upstream URL: http://sonic-pi.net/
Licenses: MIT
Submitter: ChaosKid42
Maintainer: ChaosKid42
Last Packager: ChaosKid42
Votes: 14
Popularity: 0.140540
First Submitted: 2015-05-10 19:33
Last Updated: 2017-01-16 20:28

Latest Comments

1 2 3 Next › Last »

ChaosKid42 commented on 2017-01-16 10:14

This is due to the Update to Ruby 2.4.0.
It is not caused by sonic-pi.
Unfortunately you have to recreate and reinstall all the ruby-* packages.

02m commented on 2017-01-16 10:07

I am getting the following error while trying to upgrade sonic-pi to the latest:

/usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- hamster/vector (LoadError)
from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /home/martynas/.cache/pacaur/sonic-pi/src/sonic-pi-2.11.1/app/server/core.rb:21:in `<top (required)>'
from ../../server/bin/i18n-tool.rb:16:in `require_relative'
from ../../server/bin/i18n-tool.rb:16:in `<main>'

02m commented on 2016-11-28 12:58

Thanks for the logs pointer. There I noticed that jackd failed to start because chromium was using the audio hw. After stopping chromium, sonic-pi started successfully.

ChaosKid42 commented on 2016-11-28 12:02

@02m: Please look into the log-files (~/.sonic-pi/log/*) or send them to me.

02m commented on 2016-11-28 11:29

Install was successful. However sonic-pi freezes after I start it. I only see the sonic-pi ascii art printed in the console.

ChaosKid42 commented on 2016-11-28 11:06

@02m: I added "boost" to the libs of dependencies. Should compile now.

02m commented on 2016-11-28 10:03

Build fails with:

g++ -c -pipe -std=gnu++11 -Wall -Werror -Wextra -Wno-unused-variable -Wno-unused-parameter -ggdb -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQWT_DLL -DQSCINTILLA_DLL -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_SVG_LIB -DQT_PRINTSUPPORT_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CONCURRENT_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -isystem /usr/include/qwt -I/Users/sam/Development/Supercollider/git-src/external_libraries/boost/ -I/Users/sam/Downloads/tmp/QScintilla_gpl-2.9.3.dev1606101834/Qt4Qt5 -isystem /usr/include/qt -isystem /usr/include/qt/QtOpenGL -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtPrintSupport -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtConcurrent -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtCore -I. -I/usr/lib/qt/mkspecs/linux-g++ -o main.o main.cpp
In file included from ./server_shm.hpp:23:0,
from scope.h:21,
from mainwindow.h:42,
from main.cpp:22:
./scope_buffer.hpp:26:45: fatal error: boost/interprocess/offset_ptr.hpp: No such file or directory
#include <boost/interprocess/offset_ptr.hpp>
^
compilation terminated.
make: *** [Makefile:1165: main.o] Error 1

ChaosKid42 commented on 2016-11-23 09:35

build fixed

linuxGuitarist commented on 2016-11-23 05:25

Hi, thanks for the effort. Build fails with

++ dirname ./rp-build-app
+ cd .
+ ../../server/bin/i18n-tool.rb -t
/usr/lib/ruby/gems/2.3.0/gems/wavefile-0.7.0/lib/wavefile/reader.rb:43:in `initialize': No such file or directory @ rb_sysopen - /usr/share/sonic-pi/buffers/rand-stream.wav (Errno::ENOENT)
from /usr/lib/ruby/gems/2.3.0/gems/wavefile-0.7.0/lib/wavefile/reader.rb:43:in `open'
from /usr/lib/ruby/gems/2.3.0/gems/wavefile-0.7.0/lib/wavefile/reader.rb:43:in `initialize'
from /tmp/pkgbuild-0/sonic-pi/src/sonic-pi-2.11.0/app/server/core.rb:121:in `new'
from /tmp/pkgbuild-0/sonic-pi/src/sonic-pi-2.11.0/app/server/core.rb:121:in `<module:SPRand>'
from /tmp/pkgbuild-0/sonic-pi/src/sonic-pi-2.11.0/app/server/core.rb:119:in `<module:Core>'
from /tmp/pkgbuild-0/sonic-pi/src/sonic-pi-2.11.0/app/server/core.rb:118:in `<module:SonicPi>'
from /tmp/pkgbuild-0/sonic-pi/src/sonic-pi-2.11.0/app/server/core.rb:117:in `<top (required)>'
from ../../server/bin/i18n-tool.rb:16:in `require_relative'
from ../../server/bin/i18n-tool.rb:16:in `<main>'

Putting a random wav file there made the build work, I had to delete it to make the install work though.

ChaosKid42 commented on 2016-11-22 10:33

Last update was kind of hard. Lots of changes. I didn't really test the new version. At least it builds on my machine and seems to run.

Any bug reports are appreciated...