Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - smtube-svn

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: smtube-svn 16.3.0.r7902-1

Git Clone URL: https://aur-dev.archlinux.org/smtube-svn.git (read-only)
Package Base: smtube-svn
Description: Search, download and play videos from YouTube. SVN build.
Upstream URL: http://www.smtube.org
Keywords: media player qt YouTube
Licenses: GPL
Conflicts: smtube
Provides: smtube
Submitter: Shingetsu
Maintainer: goetzc
Last Packager: goetzc
Votes: 16
Popularity: 0.570957
First Submitted: 2013-04-01 22:27
Last Updated: 2016-05-19 01:35

Dependencies (13)

Required by (2)

Sources (1)

Latest Comments

goetzc commented on 2015-05-11 00:42

As YouTube doesn't support anymore the API that SMTube was using, a new version is being developed by the main author. The new SMTube is basically a tiny web browser. The Qt4 HTML parse and JS engine are slow, compared to the new versions included in Qt5.

Therefore I have updated this PKGBUILD to use Qt5, correctly update the svn version based on smplayer-svn and the VCS package guidelines, and some minor fixes, like not depending on a particular video player, and so.

http://pastebin.com/CsGB5ppx

goetzc commented on 2015-05-08 17:35

As YouTube doesn't support anymore the API that SMTube was using, a new version is being developed by the main author. The new SMTube is basically a tiny web browser. The Qt4 HTML parse and JS engine are slow, compared to the new versions included in Qt5.

Therefore I have updated this PKGBUILD to use Qt5, correctly update the svn version, and some minor fixes, like not depending on a particular video player, and so.

http://pastebin.com/RmDKw4sF

kremix commented on 2013-12-08 23:26

bin are in the wrong places, can't start

Shingetsu commented on 2013-04-02 11:55

Pardon me, I lost the dep while patchin between qt5 to qt4; all fixed now.

grvrulz commented on 2013-04-02 11:29

Please list subversion as a build-dependency.