Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - simplicitystudio

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: simplicitystudio 4-2

Git Clone URL: https://aur-dev.archlinux.org/simplicitystudio.git (read-only)
Package Base: simplicitystudio
Description: Design tools, documentation, software and support resources for EFM32™, EFM8™, 8051, Wireless MCUs and Wireless SoCs.
Upstream URL: https://www.silabs.com/products/mcu/Pages/simplicity-studio.aspx
Licenses: unknown
Submitter: haavard
Maintainer: haavard
Last Packager: haavard
Votes: 2
Popularity: 0.004810
First Submitted: 2015-11-18 15:46
Last Updated: 2017-01-02 18:19

Latest Comments

rho commented on 2016-12-30 00:14

Tried installing with pacaur but sha256sum validation failed on SimplicityStudio-v4.tgz.
Wound up having to install with makepkg -g

Vesyrak commented on 2016-10-22 14:24

I needed to install lib32-qt4 for it to work properly.
I could get the program to start, but it wouldn't update properly (blocking access to the IDE) nor detect any hardware devices until this was installed.
I found this solution on
http://community.silabs.com/t5/Simplicity-Studio-and-Software/Simplicity-Studio-V3-Linux-quot-No-hardware-detected-quot/td-p/146807

medicineman25 commented on 2016-08-04 18:34

@haavard. hey, all good. I completely forgot about this comment. Yeh that's really weird, it only worked for me after installing qt4 and gtk-theme-engine. I know of another who had this issue and it's there I found the solution. See this post: https://cruz-monrrealii.squarespace.com/. note: I initially tried this package and it didn't function after installation. Then I downloaded the source from that post and built it, but when that didn't work and after several hours of trying, I tried this package again. By that time the only new packages I had installed were the above dependencies and qt4 and gtk-theme-engine.

haavard commented on 2016-06-14 21:18

@medicineman25, sorry for the late update. libxtst is indeed a dependency, thank you. However, I'm able to run Simplicity Studio fine without qt4 and gtk-theme-engine installed. Are you sure these should be dependencies?

medicineman25 commented on 2016-05-15 10:05

hey, I'm running 64-bit lxdm/lxde. I needed lib32-qt4, lib32-libxtst, lib32-gtk2 and the more obvious gtk-theme-engine (previously not installed). Thanks! :)

haavard commented on 2016-02-17 15:33

Fixed and fixed. Thanks!

Amadiro commented on 2016-02-17 13:52

Hey,
this package appears to need lib32-gtk2 on 64-bit systems.

subnex commented on 2016-02-11 06:14

The md5sum of one of the files does not match. To build the first md5sum has to be modified to 29a40a25986e6b24c959c93afa90b612