Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - shuriken

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: shuriken 0.5.1-4

Git Clone URL: https://aur-dev.archlinux.org/shuriken.git (read-only)
Package Base: shuriken
Description: An open source beat slicer
Upstream URL: https://rock-hopper.github.io/shuriken
Licenses: GPL
Conflicts: shuriken
Provides: shuriken
Submitter: Joermungand
Maintainer: Joermungand
Last Packager: Joermungand
Votes: 2
Popularity: 0.002343
First Submitted: 2016-01-30 21:02
Last Updated: 2016-12-29 15:44

Latest Comments

Joermungand commented on 2016-12-29 15:45

Fixed by patch released upstream. Sorry about the delay.

Aquassaut commented on 2016-12-21 13:55

Build failed at first without PKGBUILD modification. It however passed when using `make CXXFLAGS=-fpermissive` instead of `make` in build(). The errors were like so:

In file included from src/wavegraphicsscene.h:30:0,
from src/mainwindow.h:36,
from src/main.cpp:24:
src/waveformitem.h:112:50: error: ‘constexpr’ needed for in-class initialization of static data member ‘const qreal WaveformItem::DETAIL_LEVEL_MAX_CUTOFF’ of non-integral type [-fpermissive]
static const qreal DETAIL_LEVEL_MAX_CUTOFF = 0.05;
^~~~

Joermungand commented on 2016-04-18 09:28

Right! Updated. Thanks.

xantares commented on 2016-04-18 09:14

hi,
- automake, libtool and pkg-config are part of base-devel, so no need to include them
- libx11 is already a dependency of qt4, so do not list it either
xan.