Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ruby-rmagick

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ruby-rmagick 2.16.0-1

Git Clone URL: https://aur-dev.archlinux.org/ruby-rmagick.git (read-only)
Package Base: ruby-rmagick
Description: RMagick is an interface between the Ruby programming language and the ImageMagick image processing library
Upstream URL: https://github.com/rmagick/rmagick
Licenses: MIT
Submitter: shtrom
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 23
Popularity: 0.308724
First Submitted: 2009-02-25 04:53
Last Updated: 2016-10-05 08:03

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

Sopheny commented on 2014-02-18 10:13

Ty but I think you forget to add dependencies for the compilation (patch and pkg-config)

anatolik commented on 2013-12-11 23:36

I believe this should be merged into ruby-rmagick

nboichat commented on 2013-09-21 05:50

Pulled together an updated PKBUILD here:
https://gist.github.com/drinkcat/6647577

hdri.patch comes from someone else: I have no idea what it implies. Simple tests with non-HDR images seems to work fine. peteonrails on github else reported even HDR works fine: https://github.com/rmagick/rmagick/issues/18

RubenKelevra commented on 2013-09-18 18:42

Same Error here, how to we fix this?

###

checking for HDRI disabled version of ImageMagick... no

Can't install RMagick 2.13.2.
RMagick does not work when ImageMagick is configured for High Dynamic Range Images.
Don't use the --enable-hdri option when configuring ImageMagick.

###

Thanks in advance

fubik commented on 2013-09-02 07:50

Can't get it installed because it needs to have a HDRI disabled version of ImageMagick and the imagemagick package (provided by the extra repository) is a HDRI enabled version of ImageMagick.

How can we fix this ?

fubik commented on 2013-09-02 07:33

What's the difference between ruby-rmagick and ruby-rmagick2 now ? Why didn't you delete this package ?

nboichat commented on 2013-02-12 09:15

PKGBUILD needs trivial version bump to 2.13.2:
+pkgver=2.13.2
+pkgrel=1
+md5sums=('732fd61f9c0af4229a0df752ed15ffb1')

bjesus commented on 2013-02-01 23:02

after it fails, do this:
cd /usr/lib
sudo ln -s libMagick++-Q16.so libMagick++.so
sudo ln -s libMagickWand-Q16.so libMagickWand.so
sudo ln -s libMagickCore-Q16.so libMagickCore.so

kidoz commented on 2012-09-20 19:14

@egeerardyn
Done

egeerardyn commented on 2012-09-15 06:51

Please migrate from this package to ruby-rmagick: it is exactly the same and the only package that depends on this version is ruby-gruff (which you also maintain).