Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ros-indigo-rviz

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ros-indigo-rviz 1.11.14-2

Git Clone URL: https://aur-dev.archlinux.org/ros-indigo-rviz.git (read-only)
Package Base: ros-indigo-rviz
Description: ROS - 3D visualization tool for ROS.
Upstream URL: http://ros.org/wiki/rviz
Licenses: BSD, Creative Commons
Submitter: bchretien
Maintainer: None
Last Packager: bchretien
Votes: 1
Popularity: 0.000000
First Submitted: 2014-06-07 16:49
Last Updated: 2016-05-22 21:18

Dependencies (63)

Sources (2)

Latest Comments

1 2 3 Next › Last »

yiuin commented on 2016-10-29 21:54

I couldn't get this to compile with Qt4, but adding "-DUseQt5=ON" worked

hauptmech commented on 2016-06-25 20:52

eigen fixed. Build works.

hauptmech commented on 2016-06-25 06:40

Build fails because of a bad Eigen3Config.cmake recently introduced in the eigen package. Filed a bug report with that package. Fixing the file /usr/lib/cmake/Eigen3Config.cmake by hand is probably the easiest way to build in the interim.

bchretien commented on 2016-06-12 18:35

@sebastien: on a side note, Qt5 support is on the way (available since the 1.12.0 release, which has not landed for Indigo yet).

sebastien commented on 2016-06-12 11:41

@Alad
I managed to get it to build with the following symlink
ln -s /usr/bin/qmake-qt4 /usr/local/bin/qmake

alvearian commented on 2016-05-21 19:15

Doesn't build with gcc 6.1.1, with error:
src/rviz/default_plugin/effort_display.h:45:36: error: unable to find string literal operator ‘operator""fmt’

This patch fixes the issue: http://pastebin.com/XkHjNSkX

Alad commented on 2016-05-19 13:07

Now it doesn't even get past configure:

https://ptpb.pw/8m8p

Alad commented on 2016-04-21 13:04

Doesn't build: https://ptpb.pw/foPx

v01d commented on 2015-04-01 01:28

Turns I had pyqt4-10-common installed, which did not provide the .sip file.

v01d commented on 2015-03-12 17:10

The rest of the system is up to date. python2-pyqt4 is version 4.11.3-3 and ros-indigo-python-qt-binding is 0.2.14-4.