Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - renderdoc

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: renderdoc 0.31-1

Git Clone URL: https://aur-dev.archlinux.org/renderdoc.git (read-only)
Package Base: renderdoc
Description: OpenGL and Vulkan debugging tool
Upstream URL: https://github.com/baldurk/renderdoc
Keywords: debugger opengl vulkan
Licenses: MIT
Submitter: Schala
Maintainer: Marqin
Last Packager: Marqin
Votes: 6
Popularity: 0.022329
First Submitted: 2015-08-30 22:12
Last Updated: 2016-10-03 11:51

Pinned Comments

Marqin commented on 2016-10-03 11:53

qrenderdoc stub doesn't build for me in 0.31, so I've omited GUI in output package. Keep in mind that Linux GUI is still marked as work in progress and not supported by upstream.

If you want to try building with GUI then remove `-DENABLE_QRENDERDOC=OFF` from cmake invocation and uncomment two commented `install` invocations.

Latest Comments

doraskayo commented on 2016-12-16 19:26

Other than updating to version v0.32, the package needs a couple of additional updates:

* For proper Vulkan support, renderdoc.json must be placed in /usr/share/vulkan/implicit_layer.d/. [1]
* qrenderdoc is now in preview form and builds successfully. [2] While it's not fully-featured yet, it does work, and it's the only GUI available for Linux. Perhaps it should be enabled.

[1] https://renderdoc.org/docs/behind_scenes/vulkan_support.html
[2] https://github.com/baldurk/renderdoc/releases/tag/v0.32

Marqin commented on 2016-10-03 11:53

qrenderdoc stub doesn't build for me in 0.31, so I've omited GUI in output package. Keep in mind that Linux GUI is still marked as work in progress and not supported by upstream.

If you want to try building with GUI then remove `-DENABLE_QRENDERDOC=OFF` from cmake invocation and uncomment two commented `install` invocations.

Svenstaro commented on 2016-09-19 02:47

It should definitely be using libgl.

mmozeiko commented on 2016-08-25 18:16

Shouldn't libgl be used instead of mesa-libgl? So you can install this package on systems with nvidia-libgl. nvidia-libgl same as mesa-libgl provides "libgl".

Marqin commented on 2016-08-04 10:12

@damien, thanks for noticing. I've fixed that and made sure it builds using Clean Chroot. Soon I'll test patches that allow building with GCC 6.1

damien commented on 2016-08-03 13:29

The build fails due to an undeclared dependency on the xxd command, which appears to come with vim.