Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - qvim

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: qvim 20150102-1

Git Clone URL: https://aur-dev.archlinux.org/qvim.git (read-only)
Package Base: qvim
Description: A Qt Gui for Vim
Upstream URL: https://bitbucket.org/equalsraf/vim-qt
Keywords: editor qt vim
Licenses: custom:vim
Conflicts: vim-qt-git
Submitter: jdsa92
Maintainer: None
Last Packager: jdsa92
Votes: 5
Popularity: 0.000001
First Submitted: 2014-11-02 03:06
Last Updated: 2015-06-22 09:48

Latest Comments

JZA commented on 2016-06-26 11:05

Having issues with libncurses.5.so currently on libncurses.6.so
/usr/bin/qvim: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

marmistrz commented on 2016-03-11 21:20

This no longer builds. The pkgver() fails.

git describe --tags | perl -ne 'print $2 if /^(package-)([0-9]{8})$/; exit 0 if $2; exit 1'
fatal: No names found, cannot describe anything.

pmattern commented on 2015-08-18 15:39

.INSTALL is invoking gtk-update-icon-cache but the corresponding package isn't stated by variable depends.
This will probably come into effect on a minority of systems only as the package is installed more often than not but nevertheless fixing wouldn't hurt, IMHO.

On a side note I wonder whether it wouldn't make sense to rename this package to vim-qt to reflect the upstream identification.
I'm aware a package named like this was providing script http://www.vim.org/scripts/script.php?script_id=609 in AUR <4. But the last commit was more than twelve years ago.
Aside from this I for one think it would be much better anyway if scripts got summarized similarly as its done with translations, e. g. vim-script-foo.

jdsa92 commented on 2014-11-02 10:16

This is the latest stable version (see https://bitbucket.org/equalsraf/vim-qt/wiki/Packaging) whilst vim-qt-git is the most recent commit. Incidentally these currently coincide, although this hasn't always been the case.

karol_007 commented on 2014-11-02 09:57

There already is https://aur.archlinux.org/packages/vim-qt-git/ - what's the difference? Maybe you can suggest adding e.g. lua support to vim-qt-git.