Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - qt5-base-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: qt5-base-git 5.8.0.rc1.r1200.g6090c86bd6-1

Git Clone URL: https://aur-dev.archlinux.org/qt5-base-git.git (read-only)
Package Base: qt5-base-git
Description: A cross-platform application and UI framework
Upstream URL: https://qt-project.org/
Licenses: custom, GPL3, LGPL3, FDL
Conflicts: qt5-base, qtchooser
Provides: qt5-base
Submitter: plfiorini
Maintainer: vially
Last Packager: vially
Votes: 16
Popularity: 0.948967
First Submitted: 2013-05-23 15:22
Last Updated: 2016-12-30 02:31

Dependencies (36)

Required by (1000)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4

milasch commented on 2013-06-19 14:18

Forgive my ignorance, but these packages will grab latest codebase from stable branch, right? So the "20130521-1" pkgver is not meaning it clones the source code from that date. Am I right? Thanks! =]

milasch commented on 2013-06-14 21:55

Also had to manually link /usr/bin/qmake-qt5 to /usr/bin/qmake

milasch commented on 2013-06-14 21:54

Also had to manually link /usr/bin/qmake to /usr/bin/qmake-qt5

milasch commented on 2013-06-14 21:54

For some reason after installing all qt5 git packages I'm unable to run qmake:

$ "/usr/bin/qmake-qt5" /path/to/Project.pro -r -spec linux-g++ CONFIG+=debug CONFIG+=declarative_debug CONFIG+=qml_debug
Failure to open file: /var/cache/pacman/pkg/Makefile
Unable to generate makefile for: /path/to/Project.pro

ilpianista commented on 2013-06-01 14:21

Could you update this (and the others qt5-git packages) to use qtchooser as the qt5 packages in [extra]?

ATM, you cannot install qt5-*-git with qtchooser installed.
So, basically, install every binary to /usr/lib/qt/bin and add qtchooser as dependence. (No need to export /usr/lib/qt/bin in $PATH, qtchooser provides symlinks).

ilpianista commented on 2013-06-01 14:21

2013-06-01 14:12
Could you update this (and the others qt5-git packages) to use qtchooser as the qt5 packages in [extra]?

ATM, you cannot install qt5-*-git with qtchooser installed.
So, basically, install every binary to /usr/lib/qt/bin and add qtchooser as dependence. (No need to export /usr/lib/qt/bin in $PATH, qtchooser provides symlinks).

ilpianista commented on 2013-06-01 14:12

Could you update this (and the others qt5-git packages) to use qtchooser as the qt5 packages in [extra]?

ATM, you cannot install qt5-*-git with qtchooser installed.