Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - qt5-base-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: qt5-base-git 5.8.0.rc1.r1200.g6090c86bd6-1

Git Clone URL: https://aur-dev.archlinux.org/qt5-base-git.git (read-only)
Package Base: qt5-base-git
Description: A cross-platform application and UI framework
Upstream URL: https://qt-project.org/
Licenses: custom, GPL3, LGPL3, FDL
Conflicts: qt5-base, qtchooser
Provides: qt5-base
Submitter: plfiorini
Maintainer: vially
Last Packager: vially
Votes: 16
Popularity: 0.948967
First Submitted: 2013-05-23 15:22
Last Updated: 2016-12-30 02:31

Dependencies (36)

Required by (1000)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

jleclanche commented on 2014-11-09 08:23

@cuvora you need to install base-devel, please read the wiki on AUR.

cuvora commented on 2014-11-09 08:23

- makedepends=("git" "postgresql-libs")
+ makedepends=("make" "gcc" "git" "postgresql-libs")

RunningDroid commented on 2014-08-03 19:37

Here it is: https://gist.github.com/RunningDroid/28997c6d646ea2305bb6

jleclanche commented on 2014-08-02 17:07

I can't test right now. Can you gist a modified pkgbuild?

RunningDroid commented on 2014-08-02 02:35

Please add "staticlibs" to the options array and add something like:
for bin in $(ls "$pkgdir/usr/lib/qt/bin" | egrep -oe '[^/]+$'); do
ln -s "/usr/lib/qt/bin/$bin" "$pkgdir/usr/bin/${bin}-qt5"
done
to package() so that qmake-qt5 exists in $PATH

ChALkeR commented on 2014-05-20 09:13

I disowned qt5-websockets-git package.

stozi commented on 2014-02-05 21:28

The following bug appears to have re-emerged:
https://bugs.archlinux.org/task/37709?project=1&cat%5B0%5D=2&string=wayland

nuc commented on 2013-12-14 03:28

Qt 5.2 is in the repos. Are the git versions of Qt really still needed?

herrflockig commented on 2013-09-25 02:34

@stozi Adding -no-warnings-are-errors to the configure line solves that problem for me.

stozi commented on 2013-09-18 15:08

Getting this error:

cc1plus: all warnings being treated as errors
make[4]: *** [.obj/debug-shared/qsql_ibase.o] Error 1
make[4]: Leaving directory `home/user/builds/qtbase-git/src/qtbase/src/plugins/sqldrivers/ibase'
make[3]: *** [sub-ibase-make_first] Error 2
make[3]: Leaving directory `home/user/builds/qtbase-git/src/qtbase/src/plugins/sqldrivers'
make[2]: *** [sub-sqldrivers-make_first] Error 2
make[2]: Leaving directory `home/user/builds/qtbase-git/src/qtbase/src/plugins'
make[1]: *** [sub-plugins-make_first] Error 2
make[1]: Leaving directory `home/user/builds/qtbase-git/src/qtbase/src'
make: *** [sub-src-make_first] Error 2
==> Error: A failure occurred in build().
Aborting...