Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - qt5-base-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: qt5-base-git 5.8.0.rc1.r1200.g6090c86bd6-1

Git Clone URL: https://aur-dev.archlinux.org/qt5-base-git.git (read-only)
Package Base: qt5-base-git
Description: A cross-platform application and UI framework
Upstream URL: https://qt-project.org/
Licenses: custom, GPL3, LGPL3, FDL
Conflicts: qt5-base, qtchooser
Provides: qt5-base
Submitter: plfiorini
Maintainer: vially
Last Packager: vially
Votes: 16
Popularity: 0.948967
First Submitted: 2013-05-23 15:22
Last Updated: 2016-12-30 02:31

Dependencies (36)

Required by (1000)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

davispuh commented on 2015-07-09 01:33

It conflicts with qtchooser

/usr/bin/moc exists in filesystem
/usr/bin/qdbuscpp2xml exists in filesystem
/usr/bin/qdbusxml2cpp exists in filesystem
/usr/bin/qdoc exists in filesystem
/usr/bin/qlalr exists in filesystem
/usr/bin/qmake exists in filesystem
/usr/bin/rcc exists in filesystem
/usr/bin/uic exists in filesystem

jleclanche commented on 2015-04-22 20:04

@asonix can you fix your email in the PKGBUILD please? It's pointing to my domain.

asonix commented on 2015-04-22 15:43

No, you aren't missing anything. I'll fix that and get it uploaded soon.

MazeChaZer commented on 2015-04-22 15:14

Doesn't this package conflict with qt5-base? Or am I missing something here?

Manouchehri commented on 2015-03-25 06:31

Just tested again here, it builds fine. Unflagging.

mazzolino commented on 2015-03-09 00:03

Had to change the source url to use "git+https://" instead of "git://".

AnAkkk commented on 2015-03-01 10:15

Could you please update this to match the latest qt5 PKGBUILD?
https://projects.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/qt5

Zatherz commented on 2014-11-29 17:53

Please fix the package to include /usr/bin/*-qt5 files. Here's the patch:
http://dpaste.com/30TSY2C.txt

To apply:
curl "http://dpaste.com/30TSY2C.txt" | patch PKGBUILD

Raw patch (warning: breaks indents):
69a70,73
> for file in "${pkgdir}"/usr/lib/qt/bin/*; do
> mkdir -p "${pkgdir}"/usr/bin
> ln -s /usr/lib/qt/bin/$(basename $file) "${pkgdir}"/usr/bin/$(basename $file)-qt5
> done

Zatherz commented on 2014-11-29 17:51

Please fix the package to include /usr/bin/*-qt5 files. Here's the patch:
http://dpaste.com/30TSY2C.txt

To apply:
curl "http://dpaste.com/30TSY2C.txt" | patch PKGBUILD

Raw patch:
69a70,73
> for file in "${pkgdir}"/usr/lib/qt/bin/*; do
> mkdir -p "${pkgdir}"/usr/bin
> ln -s /usr/lib/qt/bin/$(basename $file) "${pkgdir}"/usr/bin/$(basename $file)-qt5
> done

Zatherz commented on 2014-11-29 16:35

Please fix the package to include /usr/bin/qmake-qt5. Here's the patch:
https://dpaste.de/r3hC/raw

To apply:
curl "https://dpaste.de/r3hC/raw" | patch PKGBUILD

Raw patch:
69a70,72
> for file in "${pkgdir}"/usr/lib/qt/bin/*; do
> ln -s /usr/lib/qt/bin/$(basename $file) "${pkgdir}"/usr/bin/$(basename $file)-qt5
> done