Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - qt-installer-framework

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: qt-installer-framework 2.0.3-2

Git Clone URL: https://aur-dev.archlinux.org/qt-installer-framework.git (read-only)
Package Base: qt-installer-framework
Description: The Qt Installer Framework used for the Qt SDK installer.
Upstream URL: http://qt-project.org/wiki/Qt-Installer-Framework
Licenses: LGPL, FDL
Groups: qt, qt5
Submitter: Schala
Maintainer: duttondj
Last Packager: duttondj
Votes: 67
Popularity: 6.191183
First Submitted: 2014-07-10 20:06
Last Updated: 2016-05-24 22:23

Latest Comments

Dokter.Bibber commented on 2016-12-31 12:24

**EDIT:** Never mind I'm installing qt-installer-framework now with makepkg.
I just don't understand why the foxitreader package didn't do that for me.
Thanks for this package.

What's up with qt-installer-framework?

[robert@designbox ~]# cd /tmp/foxitreader
[robert@designbox foxitreader]# makepkg -si
==> Making package: foxitreader 2.2.1025-1 (Sat 31 Dec 2016 12:58:50 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
[sudo] password for robert:
error: target not found: qt-installer-framework
==> ERROR: 'pacman' failed to install missing dependencies.

duttondj commented on 2016-05-24 22:24

Not totally sure what the issue is for you. I receive the same errors but the make doesn't fail for me. It's an upstream issue that can be replicated by running "make docs".

JohnRobson commented on 2016-05-20 00:05

In file included from /tmp/yaourt-tmp-us/aur-qt-installer-framework/src/qt-installer-framework-opensource-2.0.3-src/doc/installerfw.qdocconf:2:
/tmp/yaourt-tmp-us/aur-qt-installer-framework/src/qt-installer-framework-opensource-2.0.3-src/doc/config/ifw.qdocconf:1: error: Cannot open file '/usr/share/doc/qt/global/macros.qdocconf': No such file or directory
Cannot open file '/usr/share/doc/qt/global/macros.qdocconf': No such file or directory

Aborting
Makefile:636: recipe for target 'html_docs' failed
make: *** [html_docs] Error 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build qt-installer-framework.
==> Restart building qt-installer-framework ? [y/N]
==> -----------------------------------------------
==>
==> ERROR: unable to update

outofdate2 commented on 2016-05-14 17:33

Sources:
http -> https
pls

duttondj commented on 2016-03-29 15:01

Updated dependencies

rekill commented on 2016-03-29 08:39

ERROR: A failure occurred in build().
Project ERROR: Unknown module(s) in QT: qml

qml located in package qt5-declarative

Please add qt5-declarative dependency

duttondj commented on 2015-11-16 23:29

Adopted the package so I could add the qt5-tools dependency.

t0m5k1 commented on 2015-11-10 18:36

==> Making package: qt-installer-framework 2.0.1-1 (Tue 10 Nov 18:33:23 GMT 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found qt-installer-framework-opensource-2.0.1-src.tar.gz
==> Validating source files with md5sums...
qt-installer-framework-opensource-2.0.1-src.tar.gz ... Passed
==> Extracting sources...
-> Extracting qt-installer-framework-opensource-2.0.1-src.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
fatal: Not a git repository (or any of the parent directories): .git
cd src/ && ( test -e Makefile || /usr/bin/qmake-qt5 /var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src/src.pro -o Makefile ) && make -f Makefile
make[1]: Entering directory '/var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src'
cd libs/ && ( test -e Makefile || /usr/bin/qmake-qt5 /var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src/libs/libs.pro -o Makefile ) && make -f Makefile
make[2]: Entering directory '/var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src/libs'
cd 7zip/ && ( test -e Makefile || /usr/bin/qmake-qt5 /var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src/libs/7zip/7zip.pro -o Makefile ) && make -f Makefile
fatal: Not a git repository (or any of the parent directories): .git
Project ERROR: Unknown module(s) in QT: uitools
Makefile:43: recipe for target 'sub-7zip-make_first-ordered' failed
make[2]: *** [sub-7zip-make_first-ordered] Error 3
make[2]: Leaving directory '/var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src/libs'
Makefile:43: recipe for target 'sub-libs-make_first-ordered' failed
make[1]: *** [sub-libs-make_first-ordered] Error 2
make[1]: Leaving directory '/var/cache/pacman/builds/qt-installer-framework/src/qt-installer-framework-opensource-2.0.1-src/src'
Makefile:43: recipe for target 'sub-src-make_first-ordered' failed
make: *** [sub-src-make_first-ordered] Error 2



any clues as to how I fix this?

Muflone commented on 2015-11-01 17:37

Please add qt5-tools dependency

ismd commented on 2015-10-24 07:24

It's also depends on qt5-tools