Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: qgis-ltr 2.14.11-1

Git Clone URL: https://aur-dev.archlinux.org/qgis-ltr.git (read-only)
Package Base: qgis-ltr
Description: Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release
Upstream URL: http://qgis.org/
Keywords: GIS
Licenses: GPL
Conflicts: qgis
Provides: qgis=2.14.11
Submitter: saultdon
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 4
Popularity: 0.389388
First Submitted: 2015-07-08 16:37
Last Updated: 2017-01-14 06:45

Dependencies (23)

Required by (1)

Sources (1)

Latest Comments

kikislater commented on 2017-02-01 09:40

@Scimmia, what we should able to find in comments ? I've got the same error !
I think it's related to this : https://hub.qgis.org/issues/16071

Scimmia commented on 2017-01-27 22:39

Yes, known issue, see comments under the QGIS package

ingleandrobarros commented on 2017-01-27 19:44

Brother have ERROR, don't compile. Check that:

/tmp/yaourt-tmp-leand/aur-qgis-ltr/src/qgis-2.14.11/build/python/gui/sip_guipart0.cpp: In member function ‘virtual QValidator::State sipQgsDateTimeEdit::validate(QString&, int&) const’:
/tmp/yaourt-tmp-leand/aur-qgis-ltr/src/qgis-2.14.11/build/python/gui/sip_guipart0.cpp:15811:25: error: ‘sipName_QString’ was not declared in this scope

^
/tmp/yaourt-tmp-leand/aur-qgis-ltr/src/qgis-2.14.11/build/python/gui/sip_guipart0.cpp:15818:25: error: ‘sipName_QString’ was not declared in this scope
{
^
make[2]: *** [python/CMakeFiles/python_module_qgis__gui.dir/build.make:594: python/CMakeFiles/python_module_qgis__gui.dir/gui/sip_guipart0.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:3677: python/CMakeFiles/python_module_qgis__gui.dir/all] Error 2
make: *** [Makefile:150: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build qgis-ltr.

kuszi commented on 2016-04-20 08:02

Hello!

I'm not able to compile any version of QGIS on my Archlinux box :(

I'd have a good trust in the ltr release.
Build stops here:

Scanning dependencies of target python_module_qgis__core
[ 97%] Building CXX object python/CMakeFiles/python_module_qgis__core.dir/core/sip_corepart0.cpp.o
/tmp/yaourt-tmp-kuszi/aur-qgis-ltr/src/qgis/python/core/conversions.sip: In function \u2018int convertTo_QMap_3800_0600QMap_1800_0100QVariant(PyObject*, void**, int*, PyObject*)\u2019:
/tmp/yaourt-tmp-kuszi/aur-qgis-ltr/src/qgis/python/core/conversions.sip:600:8: error: request for member \u2018insert\u2019 in \u2018qm\u2019, which is of pointer type \u2018QMap<long long int, QMap<int, QVariant> >*\u2019 (maybe you meant to use \u2018->\u2019 ?)
qm.insert(k, *t);
^
python/CMakeFiles/python_module_qgis__core.dir/build.make:317: recipe for target 'python/CMakeFiles/python_module_qgis__core.dir/core/sip_corepart0.cpp.o' failed
make[2]: *** [python/CMakeFiles/python_module_qgis__core.dir/core/sip_corepart0.cpp.o] Error 1
CMakeFiles/Makefile2:3110: recipe for target 'python/CMakeFiles/python_module_qgis__core.dir/all' failed
make[1]: *** [python/CMakeFiles/python_module_qgis__core.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2


Should I cahnge something?

thanks
Robert

kikislater commented on 2016-01-16 22:57

If you don't want fcgi, modify the pkgbuild :
- comment or delete line 51 => 'fcgi: QGIS Map Server support'
- comment or delete line 177-178 => install -Dm755 $pkgdir/opt/$pkgname/bin/qgis_mapserv.fcgi \
$pkgdir/usr/bin/qgis_mapserv_ltr.fcgi

And the build works. In my opinion, it should be best to have 2 qgis-ltr package : one with qgis for desktop only and another for qgis desktop and qgis server with the required dependencies and advice for configuring fcgi under Arch ...

albfan commented on 2015-09-23 21:54

See server is disabled by default.

fcgi is an optional dep.

First lines of src/server/CMakeLists.txt says

FIND_PACKAGE(Fcgi REQUIRED)
IF (NOT FCGI_FOUND)
MESSAGE (SEND_ERROR "Fast CGI dependency was not found!")
ENDIF (NOT FCGI_FOUND)

So qgis_mapserv.fcgi is not compiled without fcgi. I guess maintainer has fcgi installed.

Install fcgi or comment that line on PKGBUILD.

attractedtofire commented on 2015-09-16 20:13

Hello saultdon,

thanks a ton for maintaining the qgis-packages here!
I only noticed today that there was also an ltr-version in the AUR. The wrong md5sum of "qgis-ltr.sh" seems to already have been fixed today but I am still not able to build - it fails with:

install: cannot stat ‘/tmp/makepkg/qgis-ltr/pkg/qgis-ltr/opt/qgis-ltr/bin/qgis_mapserv.fcgi’: No such file or directory