Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python3-aur

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python3-aur 2017.1-1

Git Clone URL: https://aur-dev.archlinux.org/python3-aur.git (read-only)
Package Base: python3-aur
Description: AUR-related modules and helper utilities (aurploader, aurquery, aurtomatic).
Upstream URL: http://xyne.archlinux.ca/projects/python3-aur
Keywords: arch_linux aur python
Licenses: GPL
Conflicts: aurploader
Provides: aurploader
Replaces: aurploader
Submitter: Xyne
Maintainer: Xyne
Last Packager: Xyne
Votes: 191
Popularity: 1.289055
First Submitted: 2011-07-04 03:22
Last Updated: 2017-01-07 09:59

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

Xyne commented on 2015-04-05 22:08

@djmattyg007
You can post in the Arch forum thread (linked on the project page) or send me email. Do you have something particular in mind?

djmattyg007 commented on 2015-04-04 02:24

Where can we go to support and contribute to the development of this module?

benjkaiser commented on 2015-01-13 03:02

@cleanrock

run this to add Xyne's key.

gpg --keyserver pgp.mit.edu --recv-keys 1D1F0DC78F173680

ponsfoot commented on 2015-01-06 17:01

@cleanrock:
Why don't you read https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

cleanrock commented on 2015-01-06 16:36

I fail to build this package now:
$ makepkg
...
==> Verifying source file signatures with gpg...
python3-aur-2014.12.tar.xz ... FAILED (unknown public key 1D1F0DC78F173680)
==> ERROR: One or more PGP signatures could not be verified!

I did
sudo pacman-key --init; sudo pacman-key --populate archlinux; sudo pacman-key --refresh-keys
before i tried to build and saw the following which i hoped would help:
gpg: key 8F173680: "Xyne. (key #3) <xyne@archlinux.ca>" 2 new signatures

Am i missing something or is this package broken ?

graysky commented on 2014-12-30 15:33

@onoakino - The download was likely bad. If you just retry it after deleting it, it should be fine.

onoakino commented on 2014-12-30 14:45

Hi Xyne. Forgive my ignorance but I was trying to do a system upgrade today when I encountered this error:

error: python3-aur: signature from "Xyne. (key #3) <xyne@archlinux.ca>" is invalid
:: File /var/cache/pacman/pkg/python3-aur-2014.12-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
debug: returning error 33 from check_validity : invalid or corrupted package
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Can you suggest what I'm doing wrong? I already did this:

sudo pacman-key --init; sudo pacman-key --populate archlinux; sudo pacman-key --refresh-keys

and still the error remains.

Xyne commented on 2014-12-30 03:37

I have added the new validpgpkeys array too all of my PKGBUILDs. Let me know if this solves the problem.

anatolik commented on 2014-12-29 18:03

Recent makepkg gives error

==> Verifying source file signatures with gpg...
python3-aur-2014.12.tar.xz ... FAILED (the public key EC3CBE7F607D11E663149E811D1F0DC78F173680 is not trusted)


I believe validpgpkeys=() is needed when using signatures

Xyne commented on 2014-12-25 03:57

he package now includes AUR.PkgList and aurpkglist to access the full list of AUR packages. See the website for details.