Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python26

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python26 2.6.9-10

Git Clone URL: https://aur-dev.archlinux.org/python26.git (read-only)
Package Base: python26
Description: Legacy version Python 2.6 of the high-level scripting language
Upstream URL: http://www.python.org/
Licenses: PSF
Provides: python2=2.6.9
Submitter: None
Maintainer: SpotlightKid (yan12125)
Last Packager: yan12125
Votes: 56
Popularity: 0.406103
First Submitted: 2010-10-14 18:27
Last Updated: 2016-11-26 13:10

Dependencies (13)

Required by (1000)

Sources (16)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

SpotlightKid commented on 2014-04-16 15:56

I made an updated PKGBUILD for Python 2.6.9 here:

http://trac.chrisarndt.de/code/browser/projects/aur/python26

(check out with Subversion from svn://svn.chrisarndt.de/projects/aur/python26)

This also fixes building against tk 8.6 and readline 6.3. For more details see the included changelog.

tasidus commented on 2013-12-10 18:12

2.6.9 security release is out: https://gist.github.com/tlatsas/7895223

maleadt commented on 2013-01-10 14:28

Okay, thanks for fixing!

remyoudompheng commented on 2013-01-10 07:55

I've added a patch that fixes the problem.

remyoudompheng commented on 2013-01-10 07:55

Please don't mark this package as out of date if you only want to report a bug.

maleadt commented on 2013-01-09 12:56

Doesn't seem to build due to dbm, see https://issues.apache.org/ooo/show_bug.cgi?id=118621. I couldn't manage to get dbm working, the first patch mendioned in that bug report doesn't apply, but disabling dbm alltogether (as per patch which is finally applied in the OoO bug thread) makes it work again.

vadmium commented on 2012-10-23 14:30

I second Untitaker’s suggestion: Please mention 2.6 (two point six) somewhere rather than just twenty-six. I was almost about to write my own Python 2.6 package from scratch. Something like this should be good enough I think:

pkgdesc="Python version 2.6"

untitaker commented on 2012-09-16 14:13

I asked to merge python2.6 into this. Please write the description so that a search for "python 2.6" will bring this package up.

Anonymous comment on 2011-06-23 00:46

I worked around the error Synthead posted below by the questionable expedient of changing the make install to make altinstall and removing 2to3, idle, and pydoc from ${pkgdir}/usr/bin/ in build(). I had to jump through some similar hoops to get wxpython installed for the resulting python26, but the program I needed to run (the Traipse build of OpenRPG to be specific) is working, so I thought I would post this in case it somehow helps someone.

Synthead commented on 2011-05-13 07:42

Here's a source package that's more up-to-date and working, kudos to le_fuzzy: http://www.mediafire.com/?vsy9utatr01s9rw