Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python26

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python26 2.6.9-10

Git Clone URL: https://aur-dev.archlinux.org/python26.git (read-only)
Package Base: python26
Description: Legacy version Python 2.6 of the high-level scripting language
Upstream URL: http://www.python.org/
Licenses: PSF
Provides: python2=2.6.9
Submitter: None
Maintainer: SpotlightKid (yan12125)
Last Packager: yan12125
Votes: 56
Popularity: 0.406103
First Submitted: 2010-10-14 18:27
Last Updated: 2016-11-26 13:10

Dependencies (13)

Required by (1000)

Sources (16)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Kwpolska commented on 2014-05-24 09:06

It’s broken. It believes the lib path is /usr/local/lib/python2.6, when it should be /usr/lib/python2.6.

SpotlightKid commented on 2014-05-18 20:19

Removed "out-of-date" flag since I can't repoduce the problem and reporter has not provided further input.

SpotlightKid commented on 2014-05-06 14:00

All tests pass on my system (Manjaro, x86_64) Except the bsdbb ones, because the modules are not included. Can you run

./python Lib/test/regrtest.py -v <test_name>

in the build directory substituting the test names that fail and send me the output (see my profile for email)? See also the "Testing" section in the README.

You can also build the package without running the test by giving the '--nocheck' option to makepkg. The commands in the 'check' function of the PKGBUILD were previously disabled (commented out) but I re-enabled them, because the tests failures were the result of actual bugs triggered by new versions of dependencies. I fixed those, so I'd be interested why additional tests fail on your system.

morxa commented on 2014-05-06 11:51

Flag as out-of-date because the build fails:
326 tests OK.
4 tests failed:
test_distutils test_multiprocessing test_urllib2_localnet
test_xmlrpc
37 tests skipped:
test_aepack test_al test_applesingle test_bsddb test_bsddb185
test_bsddb3 test_cd test_cl test_codecmaps_cn test_codecmaps_hk
test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_curses
test_dl test_gl test_imageop test_imgfile test_kqueue
test_linuxaudiodev test_macos test_macostools test_normalization
test_ossaudiodev test_pep277 test_py3kwarn test_scriptpackages
test_smtpnet test_socketserver test_startfile test_sunaudiodev
test_timeout test_urllib2net test_urllibnet test_winreg
test_winsound test_zipfile64
2 skips unexpected on linux2:
test_bsddb test_bsddb3

SpotlightKid commented on 2014-04-25 21:21

New package release 2.6.9-3

Changes:

- re-enable 'make test' in check function
- add patch for whichdb module to recognize files creatd by gdbm >= 1.9
- add patch for segfault in test_pyexpat with system expat
- add patch for failure in test_sqlite with sqlite >= 3.8.4
- add prepare function for applying patches

SpotlightKid commented on 2014-04-18 10:15

The error was in the .AURINFO file, which didn't include the pkgrel in the package version. I didn't see any mention that this is necessary in the documentation. :(

SpotlightKid commented on 2014-04-18 09:31

Not sure what you mean. The PKGBUILD has 'pkgrel' set to 1. AFAICS this conforms to the Arch packaging standards.

syne commented on 2014-04-18 09:00

at every update it tells that a new release (2.6.9) is available. in the package details there should be a release number attached to it (2.6.9-1) to avoid this.

SpotlightKid commented on 2014-04-16 20:41

I adopted it. Let me know if anything is amiss.

(I just fixed the pynche and modulator launchers as well.)

remyoudompheng commented on 2014-04-16 19:53

I have disowned the package.