Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python2-gnupg-isis

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python2-gnupg-isis 2.2.0-1

Git Clone URL: https://aur-dev.archlinux.org/python2-gnupg-isis.git (read-only)
Package Base: python2-gnupg-isis
Description: A modified version of python-gnupg, including security patches, extensive documentation, and extra features. The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.
Upstream URL: https://github.com/isislovecruft/python-gnupg
Licenses: GPL3
Conflicts: python2-gnupg
Provides: python2-gnupg
Submitter: M0Rf30
Maintainer: M0Rf30
Last Packager: M0Rf30
Votes: 5
Popularity: 0.110020
First Submitted: 2015-04-17 15:52
Last Updated: 2016-12-29 12:04

Latest Comments

KopfKrieg commented on 2016-04-07 20:09

@DoctorJellyface, @M0Rf30: I stumbled across the same issue with python-gnupg-ng. If you want to use the gnupg.__version__-string within python the package needs to be built from the git repo, not from the .tar.gz file (at least for now)

DoctorJellyface commented on 2016-04-07 15:46

I created another package based on a (working) fork in order to finish the packaging of bitmask. You can find it here: https://aur.archlinux.org/packages/python2-gnupg-ng-leap/

I have also submitted a bug report upstream: https://github.com/isislovecruft/python-gnupg/issues/147

DoctorJellyface commented on 2016-04-07 10:58

After building the version is 'unknown' for, breaking dependency version checks from other packages, any idea what the problem might be?

bgaleotti commented on 2016-03-10 16:07

@KopfKrieg just submitted a package merge request. Thanks!

KopfKrieg commented on 2016-03-10 02:45

On the next release the package should be renamed to python2-gnupg-ng (https://github.com/isislovecruft/python-gnupg/issues/47).

KopfKrieg commented on 2016-03-10 02:41

As far as I know, gnupg-1.4.0 is no longer maintained. Maybe consider using python2-gnupg-isis (https://aur.archlinux.org/packages/python2-gnupg-isis/)?