Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python2-flask-restful

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python2-flask-restful 0.3.5-1

Git Clone URL: https://aur-dev.archlinux.org/python-flask-restful.git (read-only)
Package Base: python-flask-restful
Description: A Flask extension for creating REST APIs
Upstream URL: https://pypi.python.org/pypi/Flask-RESTful
Licenses: BSD
Conflicts: python2-flask-restful-git
Submitter: max-k
Maintainer: max-k
Last Packager: max-k
Votes: 14
Popularity: 1.051679
First Submitted: 2015-08-24 11:17
Last Updated: 2016-11-21 10:12

Latest Comments

max-k commented on 2016-11-21 10:12

Putting python{2,}-aniso8601 to makedepends as a workaround brakes the build with makepkg but it's ok for me.

Updated to 0.3.5.

xantares commented on 2016-11-20 20:16

hello,

I got this error:
==> Continue installing python-flask-restful ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==>
loading packages...
resolving dependencies...
warning: cannot resolve "python2-aniso8601>=0.82", a dependency of "python2-flask-restful"
warning: cannot resolve "python-aniso8601>=0.82", a dependency of "python-flask-restful"
:: The following packages cannot be upgraded due to unresolvable dependencies:
python2-flask-restful python-flask-restful

:: Do you want to skip the above packages for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: python2-flask-restful: requires python2-aniso8601>=0.82
:: python-flask-restful: requires python-aniso8601>=0.82



as it's a split package you have to add all dependencies to makedepends:
python-flask python-six python-pytz python-aniso8601
python2-flask python2-six python2-pytz python2-aniso8601


xan

max-k commented on 2015-10-26 08:04

You can see more information here :
https://github.com/archlinuxfr/yaourt/issues/85
And here :
https://bugs.archlinux.org/task/42191

max-k commented on 2015-10-26 04:26

Hi,

It seems to be a strange yaourt bug due to the fact this package provides build recipes for python and python2.

* If you install python-aniso8601 before python-flask-restful, it works.
* If you build the package and then install it using this command, it works :
yaourt -U python-flask-restful-0.3.4-3-any.pkg.tar.xz
* If you try to install it using yaourt -S python-flask-restful, dependencies aren't resolved before build process but are delegated to pacman. This fails because python-aniso8601 is only available from AUR.

If I have a little amount of spare time this week, I'll try to contact yaourt dev team to learn more about this problem.

Thank you for your feedback.

bcc commented on 2015-10-25 22:40

==> Continue installing python-flask-restful ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==>
loading packages...
resolving dependencies...
warning: cannot resolve "python2-aniso8601>=0.82", a dependency of "python2-flask-restful"
:: The following package cannot be upgraded due to unresolvable dependencies:
python2-flask-restful

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: python2-flask-restful: requires python2-aniso8601>=0.82
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-admin
==> WARNING: Dependencies have been installed before the failure
error: target not found: python2-flask-assets>

cgirard commented on 2015-10-09 13:37

Some dependencies are missing (cf requires.txt in egg-info):
aniso8601
six
pytz