Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python-gnupg

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python-gnupg 0.3.9-1

Git Clone URL: https://aur-dev.archlinux.org/python-gnupg.git (read-only)
Package Base: python-gnupg
Description: This module allows easy access to GnuPG's key management, encryption and signature functionality from Python programs.
Upstream URL: https://pypi.python.org/pypi/python-gnupg
Licenses: BSD
Submitter: avanc
Maintainer: avanc
Last Packager: avanc
Votes: 16
Popularity: 0.348653
First Submitted: 2011-01-23 07:32
Last Updated: 2016-10-07 15:25

Latest Comments

avanc commented on 2016-08-10 19:08

@kvasthval:
Thanks for the hint. I updated the package to include the patch.

kvasthval commented on 2016-08-04 19:06

This library has been unable to verify since gnupg-2.1.13 went into [core] because of the new KEY_CONSIDERED status, breaking OneRNG among other things.
The fix is a simple one-liner and will be included in the upcoming 0.3.9 release, however they don't seem to be in a hurry about releasing it, probably because very few distros include such a recent GnuPG.
The issue was fixed in this commit: https://bitbucket.org/vinay.sajip/python-gnupg/commits/20b529201212
A raw patch is available here: https://bitbucket.org/vinay.sajip/python-gnupg/commits/20b529201212d4169e1def37033a0c49e2d8d09d/raw/
It can be fixed manually by adding "KEY_CONSIDERED" on line 248 in /usr/lib/python3.5/site-packages/gnupg.py

Also, thanks for maintaining. :-)

cwill747 commented on 2014-05-01 05:51

I'm happy to own if you want, I use this package a lot.

avanc commented on 2014-02-14 18:29

Sorry for the huge delay. I updated the package.
I don't use this package anymore, so let me know if you want to own it.

codekoala commented on 2014-02-13 05:10

avanc, do you have plans to update this package?

avanc commented on 2011-01-31 06:40

Do you have problems with Python 3?
It works without problems using Python 3 for me.

Going to update package this evening.

keenerd commented on 2011-01-30 13:43

0.2.6 is out.
Depends on python2.
Use "python2 setup.py"
"|| return 1" is no longer needed.

But thank you for splitting build and package.