Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - python-efl

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: python-efl 1.18.0-2

Git Clone URL: https://aur-dev.archlinux.org/python-efl.git (read-only)
Package Base: python-efl
Description: Python bindings for the Enlightenment Foundation Libraries
Upstream URL: http://www.enlightenment.org
Licenses: GPL3, LGPL3
Submitter: Scimmia
Maintainer: llde
Last Packager: llde
Votes: 48
Popularity: 1.526046
First Submitted: 2013-12-08 20:40
Last Updated: 2016-08-22 23:48

Latest Comments

1 2 3 Next › Last »

llde commented on 2016-09-17 21:52

This package doesn't require elementary no more from 1.18 as elementary is included in efl package and no more provided as a standalone package.
I tested right now and works for me witohut any issue.
Maybe an old PKGBUILD is readed form the cache

bowhuntr commented on 2016-09-13 11:04

This won't build.

pacaur -S python-efl
resolving dependencies...
warning: cannot resolve "elementary", a dependency of "python-efl"
:: The following package cannot be upgraded due to unresolvable dependencies:
python-efl

raininja commented on 2016-08-29 20:51

this build needs pyrex.

llde commented on 2016-03-11 10:43

Done. I'm also changing for python2-efl package.
Hope that the next update won't take this long. It was from December that the packages in extra were flagged as out of date.
Elementary stack in extra has been updated. Update the package before reinstalling "stable" release from extra.

Scimmia commented on 2016-03-10 14:35

You won't want to do that, since the -fresh versions will be deleted. Should be able to switch back to elementary in Extra, though.

chchch commented on 2016-03-10 14:17

It seems like the dependency on elementary-git can be changed back to elementary-fresh now. I just installed elementary-fresh, python-efl, and epymc with no problems.

llde commented on 2016-02-25 21:18

it's true lightdot. But as Scimmia said, it's not easy to do so.
It was done to allow the use of new features in python-efl in programs as egitu or epymc.
I'm waiting that the mantainer in the extra repo will update the englightenment packages

.Note that python-efl is not dependant on englightenment but only on the graphic framework.

Scimmia commented on 2016-02-23 21:13

In general, yes. The problem right now is that you can't build that with the current version of cython, so you're kind of stuck.

lightdot commented on 2016-02-23 20:13

Why is python-efl now depending on enlightenment-git instead of enlightenment?

Isn't python-efl-git the right package to do so?

Scimmia commented on 2014-12-21 17:38

@sb10q, what version of EFL? I just built it in a clean chroot against EFL 1.12.1 with no problems.