Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - postgresql-testing

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: postgresql-testing 9.4beta3-1

Git Clone URL: https://aur-dev.archlinux.org/postgresql-testing.git (read-only)
Package Base: postgresql-testing
Description: Beta version of the PostgreSQL database (includes both server and libs)
Upstream URL: https://wiki.postgresql.org/wiki/HowToBetaTest
Licenses: custom:PostgreSQL
Conflicts: postgresql, postgresql-libs, postgresql-testing
Provides: postgresql=9.4beta3, postgresql-libs=9.4beta3
Submitter: intgr
Maintainer: None
Last Packager: intgr
Votes: 8
Popularity: 0.000000
First Submitted: 2009-10-28 01:32
Last Updated: 2015-06-08 10:03

Required by (437)

Sources (7)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

mappi commented on 2013-07-16 07:55

Before I've looking this package I would like creating own package for PostgreSQL 9.3 Beta. I've installing and testing this AUR package and it's works fine.

Now, I have 2 proposals:
- It's there possible upgrade postgres-testing package to last PostgreSQL 9.2 Beta 2 ? And next time to Release Candidate version ?
- In Extra Archlinux repository we are 2 PostgreSQL main pacakages: postgresql and postgresql-libs. Mayube, for testing could be created postgresql-libs-testing package ?

intgr commented on 2013-05-09 20:24

Updated to 9.3beta1: http://www.postgresql.org/docs/devel/static/release-9-3.html

You can upgrade from your current PostgreSQL database with pg_upgrade (run after building, before installing the testing version):

systemctl stop postgresql
mv /var/lib/postgres/data /var/lib/postgres/data9.2
sudo -u postgres /PATH/TO/postgresql-testing/pkg/postgresql-testing/usr/bin/initdb --locale en_US.UTF-8 -D /var/lib/postgres/data
cd /tmp
sudo -u postgres /PATH/TO/postgresql-testing/pkg/postgresql-testing/usr/bin/pg_upgrade -b /usr/bin -B /PATH/TO/postgresql-testing/pkg/postgresql-testing/usr/bin -d /var/lib/postgres/data9.2 -D /var/lib/postgres/data

intgr commented on 2012-09-12 10:41

Updated to 9.2.0

@0x1997 I'm sorry, I see the mistake now (and double sorry for not reading your comment properly!)
I updated the .service and postgresql-initdb script from systemd-arch-units now, hopefully it will work for you now. :)

intgr commented on 2012-09-05 08:43

@0x1997 Upstream explicitly refused using EnvironmentFile and I am not going to maintain my own fork of postgresql.service just for the 3 users of this testing package.
Please submit to upstream, either Arch Linux directly or systemd-arch-units (https://github.com/falconindy/systemd-arch-units/). Then ping me to update it from upstream.

I've been using this service for ages now; it's ugly, but it works. Maybe there's something in your environment that needs to be tweaked for it to work.

0x1997 commented on 2012-09-05 03:46

Can't start postgresql using systemd. Please update postgresql.servie to this https://gist.github.com/3629914 or instead of adding Environment=PGROOT=/var/lib/postgres you can uncomment the line PGROOT="/var/lib/postgres" in postgresql.confd

intgr commented on 2012-08-28 09:42

Updated to 9.2rc1

intgr commented on 2012-08-27 10:40

Updated to 9.2beta4

intgr commented on 2012-08-24 10:25

Updated again, added postgresql.service & files for systemd (since systemd-arch-units no longer ships them)

intgr commented on 2012-08-24 08:31

Updated to 9.2beta3

intgr commented on 2012-06-20 08:13

Updated to 9.2beta2. Sorry about the delay :)